Snapshot Games Launcher is not downloading


#61

Ok, I found a solution on my own. For those who don’t get any way to create an account. If you right click on the launcher, then go to file location, you can find a “logs” folder. In there is info on why it doesn’t load the links. (at least it did for me) There is a big long “create account” string in it. Copy that into a web browser and you can sign up for an account, then log in, and download the game.
Still not sure why it isn’t loading the link info, but this at least gets me in the game


#62

Two and a half days and still can’t get it to download and install properly. So disinchanted with the whole experience. I think it’s the lack of help which, to me, seems to disrespect the people that have paid money to back the project. I suppose on one hand we are acting as testers and finding the proplems and bugs, but a more engaged member of the team answering questions on the forum would certsinly help.


#63

He should connect remotely to everyone who has a problem and try to resolve it? :slight_smile: This is why this forum is for. Specific cases may not be addressed. And have you tried to contact xsolla?


#64

Have you tried contacting Xsolla support via https://help.xsolla.com as it is their launcher? Other than that, as others have suggested, try turning off P2P downloads in the launcher and also running it as an administrator.

I’m sorry that you feel no one is helping or active. I’m the only social media person in the company and on Monday I worked for 18 hours straight answering questions and solving issues here, Facebook, Twitter, Discord, Reddit and via email, along with trying to provide technical support where I can (which isn’t even really my job).

We know that people are having launcher issues. They have been posted over and over, along with solutions to try. The launcher is new for us and has some teething problems. We’re still trying to work through them to make it better.


#65

I never said to connect to anybody, please stop putting ill thought out words in peoples mouths. I have contacted Csolla and as normal with them have heard nothing back. A simple well written guide to help with installation problems might well be helpful for people.


#66

But guide don’t solve all the problems which could appear. Sorry mate, I didn’t want to be rude. And I feel sorry that xsolla didn’t reach out to you.


#67

No problem at all mate, just wish that life in general could be easier😉 Pethaps a pinned note with help suggestions could be added to the top of this thread?


#68

Dont know if of any use for anyone, but using the Firefox for making/authing account, gives me a error message, but copying the link to Chrome, the link works just fine. Tho, at launch i get the error message, the game still starts just fine.


#69

Thank you for your kind reply, I’ve given up now after 7 attempts. Tried using the update fucntion last time got to nearly 100% and failed because of Error network error url = 301 = Please try again. I’m not on fibre so takes an age for it to download and then fail. Will leave this well alone now I think until the kinks are worked out😟


#70

We’re currently working on making some changes to the launcher, so will keep you informed. Also working on your suggested post for a sticky too.


#71

Bravo good sir (or madam) sorry aged and not very pc😉


#72

Any news on the fixing of the Xsolla launcher. Would really like to get into the game.


#73

No news on Xsolla fixing it. It is their launcher after all. However there is a patch to the launcher that removes he need to log in, so the login in issues should be fixed. Operative word being should.


#74

The new Laucher without the need to login works for me :+1:


#75

Does anyone have a resolution for the network errors? Both 301 and that other really long one. I have made dozens of attempts to download with admin mode, p2p on/off, deleted and redownloaded launcher, etc. Nothing works. Best I have seen is ~1.2Gb before getting the error. On top of that average speed is always around 100 kB/s +/- 50 kB, thanks 25Mb internet connection! So it is taking forever just to fail repeatedly. I’ve probably made a few dozen attempts since BB3 release with no success.


#76

Have you been running the launcher as administrator?


#77

I found a few instances of this error in other game launchers out there… Solution was apparently running as admin, as UV just said. Doesn’t appear to be much more investigation out there than that. :confused:


#78

Yep, in fact the most recent fresh download of the launcher installs with admin mode already set. I didn’t think Windows would allow that. I had 5 more fails yesterday in total the last one took 3 hours to get to ~750Mb when the 301 error popped up.

It almost feels like after several hours have passed the download location moves and the launcher loses it. If it would just download at full speed I could get it in about 20 minutes.


#79

Please send me a DM with your transaction number and email address and I should be able to offer you an alternative solution.


#80

Same here, Already disabled p2p, i will try again.