Snapshot launcher

Hi I seem to be having trouble the Launcher.
It try’s to update with 24mb download and kick me out of it when it extracting the file at 90%+ and try’s again when I restart it.

Is there anything I can do to make it update ?

have you tried running the launcher in admin mode?

Yes I tried the untick P2P and run as admin.

1st time I tried I got past the 1st update then I got a box saying its stopped working and shut down (not a windows box but one from the game launcher) the launcher.

Now I can not get past the 1st update.

when opening the launcher, as an admin, have you tried making sure the path selection has Program Files/Phoenix Point/game_Phoenix Point_22877 as the selected folder?

I can start the game from that but I have to bypass the launcher.
So am still not getting the update.

with that the game revision is “32564” and it plays fine.

I’m still on v 1.6.31, and it won’t let me update, either.

the Xsolla launcher is no longer being used. The backer build is on the Epic Launcher now.

Oh March 27th you’ll have received an email from titled "Your key to backer build 4. Check in your spam/trash folders and if using hotmail or gmail in your promotions folders. If the email you are searching is different from the one associated with your method of payment, check there. If you still cannot find it, email

BB5 is just a patch to BB4 so as soon as you download it, it’ll be up to date