Snapshot Games Launcher is not downloading


#1

The new v1.6.31 launcher is showing nothing downloading at 0 kB/s. Restarting it didn’t help.

Wondering if a port is blocked for it in Windows 10.

Never mind, problem solved. Had to right click on the “Snapshot Games Launcher” shortcut and run it as Administrator before it would start downloading. Never had to do that before for anything.

Without admin privileges it didn’t show any errors or anything. It just would never start to download.


#2

It seems since nothing in the launcher option stick. I’m concerned the updates will not roll out right!


#3

Hey All-
Having similar issues. Current version as of this post showing as 1.6.31.315

Launcher prompts for an update, click “update”, and then it flips the button to a “Busy” state, with an unmmoving “Downloading: 0.00 of 0.00 Mb, at 0 kB/s” progress bar.

If I launch directly from the executable in the game directory, I’m good, no problem, but the launcher seems to fail to pull updates appropriately, or appropriately determine whether or not it needs to pull an update and set the appropriate state.


#4

Have you tried running the launcher as administrator?


#5

That did the trick! headdesk.


#6

I don’t even see a update option? Thanks
Do I have to download the launcher again?
I have 1.6.31.315


#7

Does anyone know the current build number?


#8

1.6.31.315 is the build for the current launcher.


#9

Hi all. I am downloading BB# and launcher shows me a very low download speed 400-600 kB/s. Sometimes it became even lower then upload speed. Does anybody has same issue?


#10

server will be throttled by all the downloads, 400-600 isn’t too bad though


#11

Not really: yours is working. Mine is at 0 kB/s with the orange button saying “BUSY”


#12

Server should not be the only source. According to what I see - it looks like the main source are other clients. My Download speed sometimes falls below upload


#13

You can choose between p2p or direct i was so stupid and change in middle of down and is start again but now i got a game and is all good


#14

mine’s going from 100kps to 1mbs on a 80 mb fibre optic connection. Too many people obviously, be patient ,watch a film that’s what I’m doing.


#15

I couldn’t create a Xsolia acct. Had to use my discord. I hope they get a better gig next time this is Sh##t.
Dwnld is SL00ooow. C’mon you guys unless this Xsolia is free you got burnt!

You looking like n0obs!


#16

Well, I think I’m gonna give up for today: I can’t get any download to start, still labeled as “BUSY” , and the laucher can’t ,for the love of anything, remember my credentials. I tried to log in via steam, via discrod and then doing a xsolla account, nothing: I have to re-do the account thing for steam and discord or rewrite every time e.mail and psw for the xsolla account. Even if I check the “remember me” box in the “Settings” section of the launcher (not the login window).
I can undestand the download problems, since it’s the launch day and everyone wants it, but the credential thing is really annoying, since I’m opening and closing it trying to undestand why I can’t get the download to start.


#17

Reset your password use facebook on xsolla and then verify it on steam took a while but I managed it. I’ll admit this xsolla platform is terrible, but you can do it.


#18

I tried it, and it still doesn’t work. And the downnload is still non existent.


#19

Kind of resolved, I had to unistall everything and install it again (I used the xsolla account to enter).


#20

Now prepare for frame drops in the havens :wink: