Snapshot Games Launcher is not downloading


#41

I have the same problem as well.


#42

When I try to login, I get :network disabled’ (?)


#43

Same Problem, any Solution?


#44

Maybe if someone could post a link to create account. We could then try that


#45

Hey, I tried this on a different computer, a much older one at that. But was able to create a new account thru the launcher. Then went to the newer computer and logged in and download the game. If you can tell me where to find the link in the launcher file or just post it here, that would help a lot of people.


#46

We would appreciate not sharing the file as it should only go out to people with the correct backer access.


#47

Okay, I understand and sorry for not thinking of that. But please fix this simple bug, or at least have your support team give this info to verified customers. Instead of having us send in screen shots with no answers.
Last time I checked, that’s called Customer Service…Yep! I looked it up, it is.


#48

Hello team and people,

Same problem here, none of the link seem to be working


#49

Email Support and ask for a link to create a account


#50

Could you share their e-mail please ?


#51

It’s on the bottom of your receipt. You will need the confirm number. And to be honest, not so sure that will work. They don’t seem to be the brightest bunch.


#52

I have confirm number but there is no e-mail.


#53
support@xsolla.com

#54

OK do we have at that version have the latest game or do I need another launcher to get a update? Thanks Again


#55

Just click on the trans # or the conf. number in the email


#56

There is only one version of the launcher you can download and that launcher will download the only version of the game available. There are no different versions.


#57

Thanks for the clarity. I finally got my Xsolia acct and everything appears to be working, Now to win one!


#58

I can’t even start to download I get the message telling me the certificate is invalid so the launcher is not even installed for me. Contacted Xsolla yesterday and again today and still not able to get the launcher even installed.


#59

Did you not get the option (under advanced) to “install anyway”?


#60

No option, I click on it and it sends me to Microsoft page