Xsolla/Snapshot Games Launcher Invisible


#1

Hi all,

Not sure what is going on with the launcher, but every time I try to launch it the game launcher just doesn’t show anything? What happens it that it runs the update, and then the window disappears. I’m then left with an invisible window of the launcher with no idea what’s going on.

Have confirmed:

  • Does show up in task manager.
  • Have also confirmed Windows Defender and anti-virus software have whitelisted the launcher.
  • The “invisible” window is confirmed to be there and I am able to see the mouse change to show that I can resize the window I can’t see.

Things I’ve tried:
Uninstall + Reinstall Launcher
Uninstall + Shut Down/Restart + Reinstall + Shut Down/Restart
Reinstall graphics drivers
Run as Administrator
Mouseover taskbar item and to try to right click to maximise, but can’t actually select it.

My system settings:
Windows 10 Home x64bit
Intel i7-6700 @ 2.60Ghz
Ram @ 16Gb
Nvdia GeForce game ready driver @ ver.417.71
GeForce GTX 970M

Any other information needed?

Would greatly appreciate your help!

Thanks,
Arc


#2

Is this one you’re aware of @gamingmechanoid


#3

@UnstableVoltage @gamingmechanoid

As an update on this matter (have been trying still at trying to make this game work… am quite keen on the game)

I tried resizing the window (as mentioned before, mouse-over the invisible window does show I can resize said window) and have managed to make the launcher “appear”

However it’s not exactly resizing properly or updating graphically (if that makes sense)

As you can see below, the launcher shows itself.

I think I clicked the install button and started the prompt to select where to install the game (based on the new context-sensitive mouse-over prompt that looks like it’s allowing me to choose the install path).

EDIT That is to say I still unfortunately can’t install the game so far. That screen above is after I hit install but still not being able to see the install prompt.


#4

Send us an email at contact@snapshotgames.com - we can supply you with access to a version which doesn’t use the launcher.


#5

im also unable to get launcher to activate. I get a gray block with a red triangle that disappears so quick I cant see if it says anything.


#6

can I get that version, too


#7

Email us with your purchase details.