Launcher Update

Guys, I know there are many issues with the launcher, and now there seems to be a new one with the launcher update. Yesterday I was able to download the launcher, the game, and play it until today, with no further issues.

But then, when starting the launcher, it started to update until 80%, gave the error message “Cant extrate archive with updates” and shut down. Anyone else?


Found a work around for that.
Look in your 14.11.18.txt doc, There you will see a web site address. Copy and past without the " marks into your browser. It will download auto. Copy and paste file into SnapShot launcher folder and extract say yes to overwrite.
Am still trying to download game DL speed 32k LMAO.

Eh, it’s not working. Well, the game is running, I e-mailed Xsolla regarding the launcher, waiting for their reply (IF they reply, seeing how they must be burning with all these issues)

Sorry, it worked for me. Just wanted to throw it out there and try to help.

No need to say sorry, you were just trying to help, and that’s great :smiley:

I solved the problem, though: just ran the launcher as administrator, and that was that. No longer gave the error message, and now it seems to be fine.