Geoscape next Monday

I’m getting an Access Denied XML error when I try clicking the Windows link on the download page.

i get the same thing.

I received a link, but it’s broken. This is what I got when I tried downloading it:

This XML file does not appear to have any style information associated with it. The document tree is shown below.



<Message>Access Denied</Message>






I haven’t got any link to BB3 yet - should I be worried or?

Last time Xsolia failed as well, after contacting their support i got response with a link on october 11th which is several months after the actual release.

I wish they had never used Xsolla. they don’t know what they are doing most of the time.


I just wanted to complain that I haven’t checked my e-mail yet, so I can’t download BB3 :frowning:

1 Like

lol. well to be fair, i think the emails are supposed to roll out 15 minutes from now. But every time before, the old link worked for the latest build when it came out. its not currently working.

Second or third tiime problem with Xsolla ffs.This countdown need to stop because is pure bull …Hopefully we get links today :slight_smile:

xsolla never sent me build 2. it wouldn’t surprise me if i don’t get a link to build 3 either.

Well last time you could use old link but this time it dosent work

yeap. exactly.

honestly this is really frustrating. Is there any way we can (without violating any rules) share build 3 on this forum thru PM? I assume not. Xsolla is so unreliable and I don’t want to wait days to get to play it after contacting Xsolla’s support. I’ve done that before.

I have the email, just downloads backer 2 though…

my email down is even worded stupidly (1/2)
Product - Luxury Digital Edition

Enjoy the Game™

H + 2, no Email :frowning:

From the other thread about this from a moderator “We’re currently working with Xsolla to fix the issue. They sent out the wrong links. Will have you up and running ASAP”, so the old links will probably work they just probably tits up the server permission on the download files which is why everyone seems to be getting an access denied message. I can not be certain that is the cause, but seeing as a moderator said Xilio messed up the links and the fact the old links did work last time but this time they are having access denied errors, that seems the most likely event.

New Email from Xsolla? Have not one…

Can someone tell me why every time there is bucker build there is a problem?

It’s called time pressure :wink: