Backer Build 3 Download Problem

I just got the e-Mail from Xolla that backer build 3 is now ready for download but when i click on Windows for the Windows download version there is a XML file shown saiing “AccessDenied”.

I also testet the other versions and only the Linux Version is Downloadable.

Whats going on there?

1 Like

Got the link, but its the same like bb2. The file has the same number too.

Same here! I’m afraid UnstableVoltage’s inbox is about to explode!

Clarification : Also got the link to previous BB with same file name. The little (1) behind the file got me worried. I unpacked the file and it’s BB2, no patch or anything as advertised in other posts.

Same here as the original post. Link doesn’t do anything.

I’ve got the same as Fimbul, only the last version, not BB3.

Got the same issue!

I really was looking forward to playing BB3. So why doesnt it work!?

We’re currently working with Xsolla to fix the issue. They sent out the wrong links. Will have you up and running ASAP

3 Likes

thanks a lot

I have note received a new download link, I have the “Time remaining till backer 3 0 days, 0 hours, 0 minutes” but have yet to receive the new download link, trying both my BB1 and BB2 links just in case they where the same I was getting an access denied error.

I also haven’t received a download link and seems my topic was deleted from the forums so i will ask this here again:
Please consider switching distribution method, this is becoming a regular thing.

Last time it took them from July until October the 11th to get back to me with the download link.

UV sorry for that counter idea… But don’t worry, many of us had that hard time in the help desk. :wink:

This is what I get when I click on the download link:
<Error>

<Code>AccessDenied</Code>

<Message>Access Denied</Message>

<RequestId>70A0D97DF6F13FE6</RequestId>

<HostId>

r/slh82SZShQXRTfM/bXGFvsRnRE2huBBEgiBPg1g5GGCS5QqX6oNDsd9TLncBONOHB2nTmYIPc=

</HostId>

</Error>

I have same Problem. Didn’t get Download Link. Can you pls resend?

Still got no Link. Every Backer Build i did get no link automaticly, i always have to complain that on every build till now…

If you have the old download link that should work for you now and should point to the newest build. To get build 2 I used build 1s link because it took days to get build 2s link but the old link worked, same with this new build, still no email but used build 2s link and it now points to build 3 (which is why I am keeping all the old zips so I can play an older build if I want to) But the old link should work just fine for the new build, this time instead of a zip it downloads a launcher which then downloads the game.

Use old link, the old links point to the new builds now and they fixed the access error so should work just fine, I am currently downloading the 3rd build and I have yet to receive the link for it, just used an old link.

Thx for your Answer

what information am I supposed to log in with?

You can log in using your Steam, Discord, Facebook, Google or Windows Live account by clicking on the appropriate icon on the launcher, or you can create an Xsolla account to log in with.