Why can't I get any mods to work?

I put all the appropriate DLL’s into the Mods directory under Managed, ran Injector, it said it was injecting them, saved a new version of some file or other… and none of them work??

I’m not a software engineer - but I’m not thick and this system is ferking me off no end! :frowning:

where you put those mods?

Here is my game folder with Mods folder:


And PPDefModifier is still not used by me so you can ignore that folder. No magic, no engineering here.

Of course if you made previous steps so you have pasted into folder:
\Epic Games\PhoenixPoint\PhoenixPointWin64_Data\Managed

and run that exe file, then run the game.

Ah - mine are under PhoenixPointWin64_Data/Managed/Mods - will shift the folder to PhoenixPoint/Mods and see what happens…

OK, thanks for hte tip… but alas just moving the directory did nothing, so recopied all the dll’s into Mods and reran injector - got this:

And now nothing works at all - the Epic Launcher starts and runs, but PP is locked at:


Aaanddd… I’m screwed - deleted the mods folder - no change - still doesn’t work - how do I do a clean reinstall?? :frowning:

when you are in Epic library Phoenix Point entry has “…” on the right. left click there and select “Verify”. Before you will do that, restart your computer.

Thanks - couldn’t do that - problem is modinjector is running in the background, so fixed that.

Sooo … thanks for your patience but this is a bloody nightmare! :frowning:

Got it back to stock and ran PP OK.

Tried mods again - put all the DLL’s into PhoenixPoint/Mods, ran Injector (renaming the Assembly-CSharp.DLL along the way) - injector runs, says everything is OK… run PP… and get same problem - launcher hangs and injector is running in the background.

Shut down injector, delete Mods director, everything works unmodded fine.

Can’t see what I’m doing that is any different to what you wrote??!! :frowning:

U need to put the injector and its .dll (not mod files) files in the …\PhoenixPoint\PhoenixPointWin64_Data\Managed folder. There r total 4 .dll files that come with mod injector. (as in picture). Then run the injector. Then run the game. The Mod folder will be created under main dir like …\PhoenixPoint\Mods. Then, put ur mods in that folder.

I did all of that already - and none of it works - the “Mods” folder is created under “games” not under “PhoenixPoint”, the Injector keeps getting an error with Assembly-CSharp.DLL, plus all the other problems - so I’m giving up until someone can provide something that reaches down to my level of competence!

1 Like

I do think that not providing integrated modding support when they knew they were releasing an undercooked product was a mistake.

If they had to prepare modding support then product would be even more undercooked. :wink:

1 Like

Then, really, what they needed was a delay to release where they were now plus modding. Modding allows early pioneers to improve, co-develop, and build enthusiasm for the game.

C’mon. You knew when you played through BB5 that the next step ought to be BB6, not release.

1 Like

I think you only need to run the injector once. It doesn’t matter if the mod folder is in “wrong” location, apparently it sometimes appears in e:\mods. Don’t create it yourself, it should appear after starting pp.

Anyways, make sure you’re actually copying the injector to the phoenix point installation location, that managed-folder should be there already.

Also, if you’re using Xbox game pass, it’s more complicated since Windows completely hides the installation and you have to take ownership of the windows store folders the hard way.

OK, what if you run the injector and it doesn’t appear at all?

You’re doing something wrong? :wink:

Is it Epic version of the game? Do you have the injector unzipped where the game was actually installed?

You have to run the injector again after patches, for what it’s worth. It gives error-message that sounds like something is wrong if you run it and it’s already installed (an older version already installed) but that just means it’s working.

Yea, but what? The injector & all the other files listed above is in the correct Epic Games Win64 folder; but any time I run the Injector nothing happens, even when I Run as Administrator and say ‘yes’ to give it permission to load.

It should be in the managed folder. Along with rest of the files of course. I guess you could try running it from command line so you can see any messages.

Yep, it should, but it ain’t and I’m not computer savvy enough to figure out why.
Guess I’ll just soldier on without mods for the moment.

@MikeCC did you ever manage to solve your problem, because I think I have the exact same one.

Done everything I’m supposed to do: the Injector’s in the Win64 folder along with all its associated files; ran the game and got a Mods folder in D:Epic/PhoenixPoint/Mods; extracted the .dll file of the Mod I wanted into there (‘Allow more than 8 Squaddies on a mish’) - and nothing happens.

No idea what the problem is. I suspect there’s some super secret other file location that the Mods file should really be in that’s immediately obvious to someone who’s computer savvy, but that’s not me :confused:

Have you tried asking directly to Ijwu, the guy who wrote the code?
you can find him in discord/nexus/github