Install not working correctly

I’ve hit the install button on EPIC games and the games seems to install although the shortcut is plain and doesn’t seem to be executable. Upon clicking launch, it just opens the folder where the game is installed rather than launch the game. I tried ‘verifying’ the install as well as ‘uninstalling’ it and reinstalling it but have the same issue.

Has anyone else encountered this? Any advice?



1 Like

to be sure, you launch Phoenix Point? Not the Phoenix Point Content?

i have the same problem. Cant seem to find the executable. where do i find it. All i see on Epic stores is the launch of the Phoenix point content (brings up the listings of files) …
None of the dlcs listed in library are available

Ummm, I’m hitting the launch button on Epic games, I’m pretty sure that its the actual game. I haven’t seen any other options.

Go to ‘Library’ on your Epic games launcher and search Phoenix Point.

The Store link to install is currently pointing to Phoenix Point Content.


guys you should install and launch ‘PHOENIX POINT’ not the ‘PHOENIX POINT CONTENT’.

Ah yes, I tried to do this in a rush before I went to work. You are quite correct, I was downloading the ‘Content’ not the game! Thanks all for your time and tips! What a git I am.

Ok, this is the issue I’m having as well, but I can’t actually install the game. The content installs and opens fine. The Epic launcher seems to think the game is installed, but can’t uninstall for a clean install. Searching my computer for the game only finds the extra content files, no actual game. The button for the game always says “Resume”, never “Launch”, and clicking it does exactly nothing. Other games run fine.