Technical Issue with Epic Launcher

I paid for the game, got the code and download the EpicGamesLauncher MSI file.

Doubleclicked the file, followed the prompts and the last I remember is something like allowing access for EpicLauncher64 or something.

I can see an icon flashing in my taskbar but clicking on it won’t open it. Alt tabbing shows something but I can’t access it.

In Task Manager I see Epic launcher taking around 20% of my CPU and 130Mb of memory …bút it’s not opening and I’ve already tried to reinstall it with the same effect.

Is there a way to download the game without Epic or is there a fix for this issue?

The Epic Games Launcher is required to download and install the game (though you can run the game without it once installed). This doesn’t appear to be a common issue, as we’ve not had it reported to support. Have you tried a system restart since installing the launcher? If that doesn’t work, please try reinstalling the launcher.

If you’re still having issues with the launcher, you can contact Epic’s technical support here - https://epicgames.helpshift.com/a/epic-games-store-and-launcher/?contact=1

Did you allow the EpicLauncher outbound access to the internet. THe installer you get is actually a ‘stub’ isntaller that has to download the rest of the files from the internet. It sounds like you ran the installer, but then blocked it from getting to the internet so its basically ‘waiting’ for access to complete the install

Fixed it - it was a graphical issue.
I was using an external display, once I unplugged the HDMI and relied solely on the laptop built in display it worked fine.

Thanks for the update.

Glad to hear you resolved the issue.

What an odd cause though. That seems like a really unusual issue to stop an installer from working. I will feed this back to tech support.

Kevin, hi

I’m not sure I can say the installer was not functioning, just the graphics seemed to be like continuously refreshing on it so I could not actually click on it.

Once I’d unplugged the HDMi and the icons in the task bar stopped flashing, I was able to right click on the Launcher and change the option that was in “Run with Graphics Processor” which was admittedly a bit of a shot in the dark but seeing it was my graphics that were playing up…and now it works fine, even with my HDMI and 21" monitor.