[Resolved] Bought game though epic. 60€ version. Not working in epic launcher

#1

Bought the 60€ version via your webshop (Xsolla), but epic launcher says game unavailable for early access. Cant even download it.

Have requested full refund…

really sad that you do not match up the purchases with the distributed when this is the only way of playing the game… I do feed mislead as a customer.

Either your game is in early access and available to download and play, or you should not be selling early access versions of your game.

Everything else is just misleading.

0 Likes

#2

Did you redeem your code in the Epic Launcher?

Regards,

Jim

0 Likes

#3

Have you restarted the Epic launcher? In most cases it helps.

0 Likes

#4

Redeemed the code, have the Phoenix point in my Library, but “Unavailable”

Restart changes nothing.

and yes i did buy the 60€ version with early access.

0 Likes

#5

you need to close launcher (not just window, but the process in tray area) and run it again. If you have proper key then it should become available. Everyone have this problem. :wink:

0 Likes

#6

I did a full restart of the computer.

Only have a grayed out version in my Library.

One thing that might be messing this up is that i bought the preorder version first (though epic games), then realized that it did not have early access, and then brought one more version directly from Snapshot, and added it to epic using the key, and ordered a refund for the first pre-order version though epic games.

Perhaps epic just sucks to much to recognize two versions of the game?..

Result is the same.

Unable to download the Phoenix Point Backer Build

0 Likes

#7

Ok. Someone from developer side should investigate that.

0 Likes

#8

I’m pretty sure that it would take a time to delete the game from your library after you refunded from epic. Maybe it is also a bug in the launcher. Looks like you need to talk with epic.

0 Likes

#9

Ok so the epic guys granted me the refund for the 40€ version. and apparently deleted the version i used my redeemtion code on… so now i payed 60 for a code that is used…

brilliant…

Need some Dev to give me a new code…

This game not getting off on a good start for me.

0 Likes

#10

Send us an email to contact@snapshotgames.com so that we can look into it for you.

Nowhere on the Epic store does it say that version (the Base Edition) comes with early access. On our webstore, the Platinum and Signature Editions are listed with early access. The information is there.

0 Likes

#11

Yes,

this is why i got the epic store refund.

but now the code that i redeemed is not giving me anything on epic store, that is the version i bought for 60€ from your shop and used the redemtion code on epic launcher.

I cannot use same code again since it says this code has been used, and i have no game on epic launcher.

0 Likes

#12

it isnt out for early access. you do get a backer bulid which is a very basic idea of what some of the game will be like.

0 Likes

#13

Well, I cannot download anything. So right now i have nothing at all.

0 Likes

#15

Do you see “Phoenix Point Backer Build” in your Epic library? (Even if it’s grayed out and “unavailable”)

0 Likes

#16

No, unfortunatly I do not.

well i had (prior to them giving me the refund for the mormal version)

I think it was because I bought the normal version (no access) first, and then added the backer build.
the backer build never showed up.
I have asked and recived refund from epic from the normal version, and they removed my Phoenix Point from my Library, but that did not make the Backer build show up.

Tried restarting the epic launcer, rebooted, no changes.

And as i said previously the redemtion code that i used on the epic launcher is tagged as “used”… I cannot reuse it to add the game again…

That is why i require a new redeption code that will hopefully fix this.

But clearly some bug exist between epic launcher and the Xsolla.

Right now it seams to me like the epic launcher “ate” my redemption code, due to the fact i has a game copy (normal version) already active on that account…

0 Likes

#17

The Epic launcher and Xsolla aren’t connected in any way. Xsolla just send out the codes, which you then redeem on the Epic launcher. Seems like the fault here lies with Epic removing the wrong code from your account.

If you can send us an email to contact@snapshotgames.com we can confirm your purchase and get you a replacement key.

0 Likes

#18

Thx,

I will do so right away and refere to this forum thread.

opdate: new code solved the issue.

thx!

0 Likes