Saving Game still giving issues after hotfix

Starting new topic, because this was supposed to have been resolved in the hotfix.

Saving games still borked. What seems to be happening is the game still saves the file but stops recognising that the file is in the folder. It almost seems like there is a limit on the number of saved games allowed in the folder. If you try deleting (in windows) some of the save files while the game is open it still doesn’t recognise the files are there and still shows the deleted saves. You have to close the game down, delete the files, go back in then it will allow you to save again. The save files created during the time between the problem starting and delete/restart will still not be recognised. The files created before the problem started will still be available in the load screen. So it’s a case of deleting all the files up to the last viable one and all the files after the last one.

If you’re just clicking the save button and don’t notice then this could be from a couple of hours ago. I haven’t tried using the delete button on the save screen. Haven’t played the game enough again to have the problem reoccur since doing the whole delete restart thing.

I have played about nine hours over the weekend and lost all progress.

I can see the list of games in the folder, time stamped and everything, but cannot see them in the load saved game menu.

Very frustrating

I found sort of a wierd workaround. It only messes with the geoscape saves. Once it stops accepting saves. Do a mission and save it, do a second mission and save it, then it will start letting you save from the geoscape again. At some point it will stop accepting geoscape saves again. So repeat the mission saves.

Really no idea why that works or happens even. Won’t get your old saves back, but it does mean you can keep progress. And you have to keep save spamming until you see the geoscape saving has borked.

1 Like

I’m also experiencing this problem after the hot fix. Also, the workaround suggested by some users to delete previous save games in the save folder from windows doesn’t appear to correct the fault for me.

Won’t be wasting any more hours until it’s resolved.

Same issue here… This is annoying me…

I solved tempo with F5 quick save and restart the game again so i can be able to load the quick save and make a good save.

I enjoyed BB5, but this issue f*cks up everything

Let’s add a constructive discussion to the topic:

There is a broken save file:

The problem is that we cannot read the header of the save file:
We read the type “Object” and the size “-1”:

Hope this helps. HotFix would be nice.

3 Likes

1 Like

and now I remember this shameful times with hex editor to add some ammo and materials :wink:
thanks mate! I hope it will help!

I tried to write a utility to fix it:

Unfortunately, in most cases, not only the header is damaged.
The same problem affects other objects and arrays during serialization.

I can fix the header, since there the length is easy to calculate. But other objects are much more difficult to fix.

You can try, if only the header is damaged, this should fix the problem.

1 Like