Return to Geoscape causes game to disappear

So I haven’t been able to get too far into BB3 due to this bug, as I usually have to start over. After completing a mission (Salvage and Haven defence tested) the screen fades out indicating the mission is over, and loads the geoscape.

However, the screen flickers and presents me with my desktop after a few moments, but the Geoscape must still load, as I can hear the sounds still, but the game window is gone and can’t be retrieved, usually meaning I have to terminate the game.

If it is any help, the game still shows on the taskbar. but clicking it or alt-tabbing only gives me the audio.

Some other unrelated notes:

  • Alien turn has alot of ‘thinking’ time, I’m running this on a laptop and the CPU meter says about 25-30% during this time, so I assume this is because the ‘thinking’ is only using a single core.

  • I’ve lost 2 soldiers in one mission thanks to the autoturret, as when a soldier is grabbed by a mindfragger, the autoturret fills the soldier full of holes, not giving me the chance to remove them. Could there be an option to stop turrets from firing upon mindfragged targets?

Otherwise I am enjoying what I have been able to play, although I haven’t been able to try much beyond a few missions.

1 Like

Looks like graphics driver hanging. You have Win 10 and manually set page file?

yes, Windows 10 64-bit, the page file is currently configued on drive C: (the only drive) at 4096MB.

Or at least according to system properties, according to dxdiag; the page file is 3962MB used, 8149MB available.

I have been having some driver issues for the graphics card of late and am currently rolledback a few subversions as the latest drivers fail after a few restarts.

1 Like

Try setting page file size to managed by the system or set it manually to at least 8192 MB on your fastest drive. And update drivers to the latest working version.

Apologies for missing this before but I forgot to mention that I was using the ‘potato’ mode in the unity options, as my framerate is a bit low on ‘fantasic’. (graphics card is getting old) However switching back to fantastic seems to have fixed the issue, at the sacrifice of smooth frames.

So, still something to investigate, but for now I can play beyond one mission :slight_smile:

1 Like