Backer Build 5 bugs

So I’ve been able to play BB5 more than the previous BB’s, but there’s still numerous issues I’m dealing with where I can’t hit F12 when it appears.

  1. Freeze on loading an Auto Save.

  2. While in combat, screen goes black, but game still runs in the background. Can’t alt+tab or minimize or open. Have to kill the game.

  3. And the most annoying… Play for a few hours. Exit. Come back and there are no saved or auto saves, only the ones from the day before.

Number 2 and 3 seems to happen more frequently, but 3 is enough to not want to play the game. Hopefully these get resolved soon, so I can play it some more. Definitely a great game.

1 Like

On number 3, I did post about this in another topic, but in case you don’t see it. The save thing only seems to bork at geoscape saves. So you can still save during missions. The weird bit is that if you do two mission saves it then allows you to start geoscape saving again. This will eventually bork out so you need to repeat. Thing I haven’t tried is if these saves can be in the same mission, will try that next time. So you need to hit the save button then check the time on the save file to make sure the save has worked.

1 Like

That is annoying. I wonder if some report goes to Snapshot when such thing happen? Because game don’t allow us to do much then and then it just goes to desktop.

1 Like

BB5 o iMac 2019.
infinite login screen after “made with unity” logo. No sound, no graphics, forever loading. Be it Fantastic graphic settings nor potato settings on 1024 size.

that is just the loading screen taking forever. It is still loading though. Longest I’ve heard of is 10 minutes. The loading in-game is normal though

Yes, you are right. Music starts after one and a half pie.

Atleast this still shows numbers and colours, mine goes completely black, like someone unplugged my monitor.

In my case, it doesn’t matter where it’s saved. I mean I’ll play for about 5 hours. Save in Geoscape, Save in Mission, and even the auto saves… I exit, then come back maybe 20 mins later, and it’s ALL gone. Only the saves from the previous night is available. It’s super annoying after all the time spent in it, just no motivation to play any further.

try saving and then checking in loading screen if it is available right in this moment. If it isn’t try to save few more times. It is easy to distinguish which saves will work and which not. Those which will fail, save really fast (like 0.1 sec), while those correct takes time like 1 or 2 seconds.

Let say it clear. It’s not ‘saves will work’ but rather ‘is saving operation successful’, IF saving is successful (visible on the loading screen) you still may get the ‘empty globe’ error after loading this particular save. These are two separate bugs.

1 Like

Hi, I had similar experience as you did with the saving. It is really extremely annoying - I have lost only like an hour of gameplay, but still, that is something which really discourages you from opening the game again. Hope they will fix this one for the final release, because that is really like a no-go for me…