Game is now unplayable after a few days progress

The game hangs returning to the geoscape after a tactical mission. Usually, any of my geoscape saved games will not load at this point as I don’t keep dozens of saved games. Tactical saves load but however I end them, they hang trying to load the geoscape. I haven’t seen any of the tactical game hangs anymore but that is because I haven’t gotten to the point in the game where chiron with fireworms start appearing. The geoscape load bug hits me first and at that point all my saved games are have the bug in them.

Herb (aka XCOMDOS)

Something else new as well, can’t send the F12 bug reports anymore? All I get now when I press it is the volume control for the computer (which is its default) so it is not even registering the keys now? First time it has done this?

1 Like

i’m able to send F12 bug reports so far. once again, my set of saved games all could not be loaded because the game keeps playing fine for a long time past the point where the save files start going bad. it’s only easily 15 or 20 saves later, including autosaves, that whatever causes the lockup returning from a tactical mission to the geoscape kicks in. anyway, a couple of days playing are shot because of the bug in all save files.

Herb (aka XCOMDOS)

Yeah Ive had the geoscape freeze a few times now.
I started new campaign twice hoping it wouldnt reoccur.
Its only after having played for a considerable amount of time that the freeze happens.
Very frustrating.
Anyone know of tricks to work around it?

I had same issue with freezing at geo after mission. I found a solution. It starts to happening after researching “Factory Automation” tech. Completed reseach throws exception in log and stays in research queue and after next misson you will be stacked at geo. I loaded previos savegame and removed “Factory Automation” from research queue. It solved the issue for me.

Maybe issue is connected to all faction tech which are not instant

1 Like

Exception i got in log
Exception: Cannot get research that is locked to a specific faction
at PhoenixPoint.Geoscape.Entities.Research.Research.GiveResearch (PhoenixPoint.Geoscape.Entities.Research.ResearchElement research, System.Boolean copyProgress) [0x0003e] in :0
at PhoenixPoint.Geoscape.Levels.GeoFaction.ShareResearchWithAllies (PhoenixPoint.Geoscape.Entities.Research.ResearchElement research) [0x00047] in :0
at PhoenixPoint.Geoscape.Levels.GeoFaction.OnResearchCompleted (PhoenixPoint.Geoscape.Entities.Research.ResearchElement research) [0x00013] in :0
at (wrapper delegate-invoke) .invoke_void_ResearchElement(PhoenixPoint.Geoscape.Entities.Research.ResearchElement)
at PhoenixPoint.Geoscape.Entities.Research.Research.OnResearchCompletedHandler (PhoenixPoint.Geoscape.Entities.Research.ResearchElement research) [0x0000a] in :0
at PhoenixPoint.Geoscape.Entities.Research.ResearchElement.Complete () [0x00059] in :0
at PhoenixPoint.Geoscape.Entities.Research.ResearchElement.OnStateChanged (PhoenixPoint.Geoscape.Entities.Research.ResearchState previousState, PhoenixPoint.Geoscape.Entities.Research.ResearchState currentState) [0x00043] in :0
at PhoenixPoint.Geoscape.Entities.Research.ResearchElement.set_State (PhoenixPoint.Geoscape.Entities.Research.ResearchState value) [0x0000e] in :0
at PhoenixPoint.Geoscape.Entities.Research.Research.CompleteResearch (PhoenixPoint.Geoscape.Entities.Research.ResearchElement research) [0x00000] in :0
at PhoenixPoint.Geoscape.Entities.Research.Research.AddResearchToQueue (PhoenixPoint.Geoscape.Entities.Research.ResearchElement research) [0x000a0] in :0
at PhoenixPoint.Geoscape.View.ViewModules.UIModuleResearch.AddToQueue (PhoenixPoint.Geoscape.View.ViewControllers.Research.ResearchListItem listItem) [0x00011] in :0
at PhoenixPoint.Geoscape.View.ViewControllers.Research.ResearchListItem.b__26_0 () [0x0000a] in :0
at UnityEngine.Events.InvokableCall.Invoke () [0x00011] in <4b072c28d0804e3e8741f43de2d5aec4>:0
at UnityEngine.Events.UnityEvent.Invoke () [0x00023] in <4b072c28d0804e3e8741f43de2d5aec4>:0
at UnityEngine.UI.Button.Press () [0x00027] in <7226f90031be42f8b766865f7b6a0c1d>:0
at UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData) [0x00011] in <7226f90031be42f8b766865f7b6a0c1d>:0
at UnityEngine.EventSystems.ExecuteEvents.Execute (UnityEngine.EventSystems.IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData) [0x00008] in <7226f90031be42f8b766865f7b6a0c1d>:0
at UnityEngine.EventSystems.ExecuteEvents.Execute[T] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.ExecuteEvents+EventFunction1[T1] functor) [0x00070] in <7226f90031be42f8b766865f7b6a0c1d>:0 UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object) UnityEngine.DebugLogHandler:LogException(Exception, Object) UnityTools.LogFormatter:LogException(Exception, Object) UnityEngine.Logger:LogException(Exception, Object) UnityEngine.Debug:LogException(Exception) UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction1)

(Filename: Line: 0)

Ill look out for that next campaign round :slight_smile:

Just tried it with other “not instant” faction techs - got same issue. I beleive this issue corrupts CurrentGeoscape file. File can be rewritten by completing a misson, but it needs “in mission” savegame to be loaded first

i have noticed things in the research queue not clearing but i had not thought to check further. it seems that being able to complete a tactical mission sometimes clears it. i will have to try on the next game but i am getting discouraged with playing and knowing i have only a day or two’s playing time and then the game hangs and can’t be continued.

Herb (aka XCOMDOS)