Phoenix Point Game Key issue

I purchased the Phoenix point edition with the early access. When I redeem the code with epic it tells me that there is an error with the code. Do I have to wait a certain amount of time for the code to become usable?

have you tried close the launcher in the system tray and reopening it? There is a known bug where the Epic Library doesn’t update to show the game unless you do that

Well it’s not that the game doesn’t show up, it just says “Request Failed with status code 400” when I try to input the code

the reason I asked is because as far as I know the Epic store still doesn’t give a confirmation that the code was accepted and just looks like it timed out. As a result some people will input the code a second time and get an error.

I’ve closed the launcher too and it still does not show up. So I’m at a loss as to what to do now

Update: it now says the code has already been used when redeeming through the epic website. Still does not show up in my library.

just double checking that you closed in the system tray and not just hit the X (which only minimizes the launcher)

I closed it through the system tray

in that case, I’d send an email to and ask them for help. It is the weekend so there will likely be a delay before UV gets back to you.

Okay thanks, I appreciate the help

you’re welcome. Sorry I couldn’t be of more assistance

I was thinking only I am facing this issue.