Platinum Edition?

#1

Hello.
I just bought the platinum edition and, so far, it is a little bit disappointing.
a/ I indeed received the link for the game. It is accompanied by a short document describing Backer Build 03. That’s it.
The game manual is absent and the one supposedly included in the game itself does not load. It freezes everything in fact. The solution is to get out and restart. I’m on Mac by the way.
b/ All the goodies supposedly included in the platinum edition, that could have helped me understand exactly what to expect and what to do, are missing. I hope I will receive all this very soon. The most important thing is obviously the game manual. I can obviously understand if it is not final yet.
c/ The game does launch and the geoscape part seems to work. But nothing really happens except when a scavenging site appears.
d/ The tactical part seems to have a serious problem of display. As soon as a soldier seems to get close from a wall, the screen gets black and white, with the soldiers icons still appearing however. It is quite strange and prevents any possibility to advance and finish a mission.
e/ At first glance, graphics look nice when they appear normally. I can’t really speak about combat, as I have not been about to try it much.

All together, this is not a very encouraging start, but I remain hopeful that the display issues will be solved quickly.

0 Likes

#2

That’s because you’re not receiving the game, the game isn’t even launched, you’re receiving an alpha demo.

When the game goes out you’ll receive all your goodies. (If not changed that will be in september)

0 Likes

#3

And that is it. :wink: People who bought higher tiers also wait for content. You will need to wait for final release to get all goods mentioned in Platinum Edition.

There is not much in this build which can keep you all the time busy. But try to watch some gameplay videos to check out what is there. Example:


or watch videos from UnstableVoltage, he is from developers side here :slight_smile:
0 Likes

#4

Thank you Berggen. I understand this is only a alpha demo. But I was expecting to get the game manual, even if it obviously not complete. The other goodies can wait.
It also seems that other people can complete some missions. They don’t seem to experience the display issues I have met.
I’ll try again tomorrow.

Thanks.

0 Likes

#5

There is no game manual at this stage, only the PDF “Game Guide” which is what the button on the main menu is supposed to link to (though this button sometimes doesn’t work due to the installation directory).

As Phoenix Point is currently in pre-alpha (not feature complete), work hasn’t started on a manual. Many things are currently missing or likely to change between now and release.

0 Likes

#6

A few things to help, maybe:

You’re playing an alpha demo of what the team is working on, not even a beta yet.

Manual should be located in install directly and can be opened from there. Even in game, it just opens a browser window with it. There’s also a few threads in here with tips about things that aren’t mentioned in the manual.

The rest of the preorder stuff is meant for release.

Your display issues aren’t something I’ve seen mentioned here that I can recall. It’s very likely a problem on your rig, or possibly with the Mac build specifically. Including your hardware and such would be very helpful for someone on the team to try and get that resolved. Anything Mac has similar to a directx diagnostic as well. Wish I could do more there, but no experience with macs really aside from trying to get Sims 4 running on my gf’s years ago.

Backer Build 4 is coming soon, with some extra geoscape stuff. It may solve your issue on its own, but any info you can get them right may help to prevent it from being in bb4, or help it get patched up quickly.

0 Likes

#7

Also, this link may be helpful:

I also remember advice I gave someone else about a different game. I’ve had good luck in the past by searching for a specific issues and unity together in the past. So something like screen whiteout blackout near objects unity Mac. Sometimes you get lucky!

0 Likes

#8

Thank you very much. I tried playing without the free camera option. I don’t get the black and white screen anymore. There is kind of a freeze (the camera goes to the end of the field and it is not possible to go back to the soldiers.
It might indeed be an issue with Mac build. My MacPro is fairly recent, with a AMD FirePro D300. It gets the job nicely done for XCOM2…But PP is obviously different and, as you rightly mention, it is still in the development stage.
Thanks for the advice to let Snapchat have a look, especially if it helps them for the building of BB4.
Rgds

0 Likes

#9

Glad to know you got some working. I’ve had a bug on PC sometimes, not sure if it was with PP or xcom or wasteland, where the camera flies off on a diagonal, and just acts like the cam movement key is pegged down. Only suggestion I have with that is to try clicking on a soldier class symbol a couple times and see if it’ll recenter.
It’s definitely still early, and I’d guess the Mac side of the team is smaller, so optimizing on that end will probably take a little longer. Pure guesswork on that though.

0 Likes