HOTAS bug still present!

Hi there!

Some back ground info:
I was a alpha backer and we tested every patch…
I have a HOTAS set up on my pc for playing Elite Dangerous(a lot)…

During the 1st and every patch after that, and during all this testing i reported that my HOTAS set up was interfering with the cursor on screen, basically making it vanish(like some smart mice did), and that now invisible cursor would randomly zoom across the screen. Which makes the game totally unplayable.
All through the Alpha & beta stages I reported this, in every patch…
Many others have also reported the exact same issue…

We are now at the games release… the bug is still there… How?

As every other game in my pc does not have a issues with the HOTAS, this includes Xcom EA & WoTC + packs…Just to point out your closest competitors got it right, and no issues…

A solution from some mod on your forum “Simpy unplug the HOTAS, and try to run the game”…
Hmm no, why should i have to crawl about under my desk, unplug several cables, just to run a game… that 99.9% of other games have no issue with…And don’t forget that we paid for this game to happen.

Only to crawl back under, plug them back in, verify them with windows, etc…And if i want to play PP i have to crawl back under & unplug them again if i want to play a game i payed a lot of cash for…
Please look into the frustrating issue.


In case it isn’t obvious: priorities. Those competitors have about 1000 times more budget. Snapshot has to be picky. You are about the only one that keeps HOTAS plugged in while playing so of course it’s not #1 on the list.

While xcom may not have a problem with it, peripheral interference and even peripheral drivers interference has been around for a long time and still regularly affects games to this day. It is by no means unique to Phoenix point. Should they fix it? Sure. Should they fix it RIGHT NOW? Not really. It’s an edge case with a simple end user solution.


i’m not owning PP yet (still waiting for the MS Cert to be done with) but for your problem…

What HOTAS are you using? X52? If so, you could just disable the Mouse ministick that maybe causes for troubles.

Here is a Video of someone:

If that didn’t work and you don’t wanna crawl under your desk, you could try to disable the HOTAS in your device-manager. Its not the best solution, but at least no “sports” required. :wink:


I’ve got a HOTAS myself, an old X52. There’s a small rubber-tipped “hatswitch” on it which used to interfere with my screen cursor. Setting up a “dead zone” on it fixed the issue.

1 Like

I use the wharthog hotas :stuck_out_tongue:

I’ve not heard of that one. I am however familiar with the “Warthog”. :clown_face:

Well you must be a ray of sunshine when the code to disable remote devices only takes 2 lines. Get your coding degree in mine craft there Omenomaho?

Thank you to the others of the thread to offer the other solution vs the idiot opinion…helped me!