Game locks in Enter Synedrion, Stage Left mission (1.14.3 GOG))

I was playing “Enter Synedrion, Stage Left” mission (Legend difficulty, modded - no errors in Modnix log file, happens only in this mission), somewhere mid-game, and notice there was an Infiltrator class enemy among the Independent enemies in the mission. He was carrying Psyche IV crossbow, even though Synedrion hasn’t researched Venom Crossbow, or I haven’t noticed, and every time he tried to shoot at my soldiers, the game locks, and I’m forced to shut the game down. I’ve managed to pass the mission by lure that Infiltrator and kill it before it had chance to shot. Had no problems with Independent enemies.
Tried the mission 5 times and every time it hangs when Infiltrator tries to shoot.
After the mission, I tried to steal Aircraft at the same Heaven, and there were Infiltrators with Eros III Crossbows (3 of them), and the game played normally.
P.S. Even tried the mission, after removing all Psyche IV releated entries in mods (JS .json files), and it hanged again. The version is GOG 1.14.3.

Thanks for detailed report. You did not say if you tried it without mods so I just tested it on GOG 1.14.5 (which is the latest version but I am pretty sure it does not make difference) and it works fine. I let the infiltrator shoot and no hang, it worked properly so I think your problem was caused by mods.

I will try it later. After disabling mods, do I need to start a new game or I can reload the save before the mission (since I use mods that alter the difficulty and fully changes the weapons, equipment, mutations, bionics, vehicles and aircrafts)?

I do not really know. It may or may not cause problems. As you are in the beginning of your campaign I would probably start over if I were you to be safe.

I’m not at the start, I just posted it wrong. I’ve said: mid-game, when I meant mid campaign, my bad. I’ll start it again.

Found out that one of the files was causing this. Feel free to delete this topic.