Extremely low FPS and Loss of .exe file upon force quit

I’m sorry I can’t test the game: I’ve tried a map the first day, I got quite a bit far into into it, but the continuos stuttering of game, both visual and audio is unbearable. I tried updating the drivers, I tried windowed mode and reducing the resolution (last time I tried 800x600). I doesn’t get any better, the menu alone has half a second of delay between the mouse and the highlighting of the options (the audio is ok). The game has up and downs in performances, you can havee 1-2 even 5 minutes of almost ok experience, but the rest is full of stuttering of the the visual and audio, and when using explosive frames drop 2-3 seconds per frame (and around 20-30 seconds for the full rocket launch animation, I least I think there is one from the youtube videos because I can’t possibly see it in this build).

Moreover, upon force quitting the game during the mission (not with alt+F4, but with the X button on windowed mode) the .exe file disappears. I had to re-download the game to try it again: It is not possible to get it from the .zip file because it deniens me the access.

Edit: It is possible to get back from the zip file, but you have to do it in a new folder, you can’t unzip that specific file in the old folder.

The loss of the .exe file happened twice.