Frustrating game crash and file not found


#1

So this is the second time, first time i just thought " oh well, things happen, just download again " but the download speed here is to low to download 6.6 gigabytes in one strike so i have to go to a friends place to download it.

Anyway, back to the problem:
first time after a game crash, it hanged actually and after i waited and waited i closed the game from desktop. Turned pc off and when i turned it on wanting to play PP the launcher’s telling me " file doesn’t exist" but after checking twice it was all in the folder where i left it and installed it but the launcher wouldn’t think about it once i tried to tell him otherwise going manual, so i was forced to trash everything and download from the start.
After 3 days ( this evening after the last update ) i brought the manticore back to one of my bases and opened the trooper menu to look at the new features, closed it and quick save. The moment i clicked on the quick save button the game freezed.
After waiting a while i closed it from desktop. 30 minutes later i tried to play again, click play button from launcher, logo appears but then the game hang on the loading screen, tried again exit and play but it did the same hanging on loading screen.
After a deep breath i turned off the pc the restart it and guess what? once opened the launcher it tells me " file doesn’t exist".
Just frustrating… trying to repair the game now but from home it will take ages…


#2

Here’s something that might help: open up the folder where you installed the launcher, then look at launcher_settings.ini in a text editor. There should be a line that says 22877..GAME_PATH=C:/Program Files/Phoenix Point or something similar. Check that this path points to the folder where the game .exe is installed: for example, if it is 22877..GAME_PATH=C:/Program Files/Phoenix Point, then the game .exe should be located at C:/Program Files/Phoenix Point/PhoenixPointWin64.exe. If it’s not there, then change the GAME_PATH line to point to the folder where the game .exe is and reload the launcher. Hope this helps!


#3

seems actually the PhoenixPointWin64.exe file is missing.

anyway i’m downloading it again, perhaps if there is a way to prevent this from happening i would be really thankfull.


#4

It’s most likely your antivirus or windows defender deleting it.


#5

You’re telling me my antivirus is a damn crablover? How can I prevent it?


#6

Make an exception for Phoenix point or shut down av before trying to play. Also, once you get it reinstalled, copy the. Exe to another folder as backup so you have to keep repairing if it does delete again.


#7

Thanks to all for helping me out here, I will make precautions this time, make a new game instead of continuing the old one etc.


#8

Also, meant to say, it’s best if you add the entire PP folder to the trust list, also. Theoretically a little dangerous if you do get an infection.


#9

Downloaded the game again, installed, copied the .exe in a different folder. Started the game but it just hang on the loading screen… what can I do now?


#10

Increase size of page file?


#11

Copying exe is just to give you a way to recover without having to re-download. Did you set everything to launch as admin and disable your anti-virus and/or exclude the Phoenix point folder from it?


#12

So what would be realistic game memory footprint? 8-16GB?


#13

Hard to say. But I suppose 8 GB is enough


#14

I ment physical RAM + page file recommended.
If 16GB is recommended for game, then its 16GB always and 8GB RAM users need at least 8GB swap. That is game alone + what Windows and resident apps eat.