Frametime stuttering when I change camera view, reclick units, moving

I tried search similar topics, but it’s surprising not much people complain about it. There was only old posts in december and that’s all about it.

I’m using good hardware (i7-9700K, 32 GB RAM, RTX 2080 Ti, Windows 10), and I’m pretty sure this is game optimization problem.

Moreover I experienced exact same problem in other games which also use Unity Engine (Two Point Hospital also stutters during map scroll).

Some people says it’s happening because of how game engine works with texture processing. It’s continuous process depending what showing on my screen.

Is anything I can do to decrease this effect? Maybe I can disable memory limit that game can use? I suppose all that texures that constantly load and unload during map scrooling is possible to keep in memory, moreover my PC have lots of free RAM. My GPU also have unused memory.

Phoenix Point is using the Unity Engine, not Unreal.

My own system specs are actually below yours (i7 6700 (not even K), 32GB RAM, 1080 GTX) but it’s not an issue I’ve noticed even on the highest settings.

The best thing is to hit F12 in game when you’re experiencing the issue and send a bug report directly to our QA team, as this will send important game and system data to help them track the cause.

I suffered 0-1 FPS whith a few animations, like jumping

Do you mean using the jetpack/jumping legs? There is an issue at the moment where there’s a few frames of lag when the skills are activated while the game processes all of the valid movement spaces.

Yes, lag is impressive, it takes many seconds to complete the animation

And about the OP, I have a great rig:

Ryzen 7 3800x, 32GB DDR4 3200, RTX 2700 Super 8GB, SSD 1TB 3500Mb/s

and right now playing final mission, with all the creatures at the same time, I notice the lag, I set always max settings, I don’t know if it’s about Unity engine or something else

I get this some times on the big maps at the start when I skip the landing video, a few times with the jetpack when at max height. some times I even get the opposite and the animation goes very fast.

Ryzen 7 3.4GB, 16GB DDR4, vega 56 8GB, 2 x 1TB WD HDD, 1 2TB WD Black HDD. Win 10 64bit.

I sent two reports, first about problem itself and second with some additional info. Aside from this problem found strange bug, sometimes game trying to cap own fps to 72. I can have 100-140 even in complex scenes with a lot of geometry and it occasionally cap on 72, still can’t figure out when exactly it happens. So probably stuttering and fps capping somehow connected.

In my case stuttering happens even on first scavenging missions.

I record a video with this issue. On video I activate as addinional info Afterburner stats where every time I trying interacting with map it show frametime spikes up to 100 ms.

I tried last build of the game (Cthulhu 1.6) and there’s still no fix for stuttering issue.

Framerate is stuttering with every single action in tactical mode. Reclicking units, moving, scrolling map, AI move. Basically anything with camera view changing.

I refer this to bad Unity engine optimization. So can we expect some improvement in future or with incoming new DLS’s maybe?

That problem may be related to cheathappens trainer. Do you use it?

I don’t use any trainers or any external software which could have any effect on my hardware.

Everybody have this stuttering more or less, I watch sometime streamers who play Phoenix Point and I see same effect when they moving camera.

I have the same problem with a good computer. Lag starts sometime and stops suddenly. Not a game breaker but annoying for sure.

I don’t think the devs have found the sweet spot with their tweaks to the latest Unity Engine. They introduced quite a bit of issues that need addressing.

Same problem here. Stuttering example

You can watch a good demostration of this issue. I can call it “barely playable”… Remind that I have RTX 2080 Ti and i7-9700k.

Extreme drops when:

  • Change camera position
  • Click on next unit
  • Unit end it movement (drop happens immediately after this)
  • Zoom in and out in shooting mode

You can see I have always more 60 fps. On 1 minute I tried limit my FPS using RTTS to 60 frames, but doesn’t matter because it start dropping from 60 to 30 in this case.