EGS: Expansion Pass does not grant Festering Skies

Buying the Expansion Pass on the Epic Games Store is supposed to grant the Festering Skies content, but it currently does not.

I own the Year One Edition of the game, then purchased the Expansion Pass today. Here’s how my game store page looks, showing that I own the Expansion Pass:

Then here’s my list of add-ons for Phoenix Point, which does not include Festering Skies as I expected:

In-game, when starting a new game, I do not have the option to use Festering Skies:

Other players on the Discord chat just said the exact same thing happens to them. I’d like to know when this problem gets resolved, so that I can use the Festering Skies content I just purchased.

I have same problem, I bought the Expansion pass as I own previous 2 DLCs, and it doesnt activate Festering Skies. My epic store looks exactly like yours

Have you tried shutting down the Epic launcher and restarting it?

Yes, I did, twice, and it changed nothing. I also tried the “Verify” option on Phoenix Point, twice, which also changed nothing.

I have the same issue, contacted Epic Support and after a few mails back and forth (restarting the launcher etc) they told me i would have to contact the developer directly.

The dlc is now showing up for me.

As I said in chat, I just got the DLC now, so the issue now seems fixed, thanks.

Just so all are aware, this should be resolved and working properly now. Our apologies for the inconvenience… now go get that Behemoth!!