Year 1 Edition -- DLC Not Owned -- Help?

Sorry, I did not know where to post this, but I figured I might not be the only one having this issue.

I purchased pheonix point back in early access. I can’t remember if it was before or after the move to Epic Games, all I know right now is that I own it on Epic Games. The game in my library says Year 1 edition, but in Game it says I do not have the DLC.

Since it said that I did not have the DLC, I attempted to purchase the year 1 upgrade from Epic Games… but the transaction ended in the error ‘You already own this content’.

Hoping to get some assistance with this or be pointed to the proper place to submit this issue.
Thank you!

I got the same exact issue…

Purchased the Digital Deluxe version back in EA before hte move to epic i also got the Blood and Titanium DLC on epic…

Now it says the edition is a year one edition but the Legacy of the ancients DLC is not available. Also tried to purchase the year one upgrade since that’s the only thing that is available but it says you allready own this.

So right now it seems like there is no way for us to get the Legacy DLC??

Any solutions to this?

Can you specifiy if you’re on Steam or EGS

Steam had a problem with some of the DLC not being enabled, but that bug has now been fixed

On EGS it works fine, when you start a new game, the irght hand side (where you select difficulty) will allow you to enable/disable the 2 DLC packs

The year 1 dlc should be active on your account.

Note purchasing the Season Pass upgrade seems to be bugged on Epic’s end. The devs are aware and are looking into solutions

It’s on EGS and ingame when you start a new game it says Now Available on the Legacy DLC and when you click that you get directed to the store page.

Which you can’t actually buy because EGS think’s you allready own the Year one edition. So as it stands right now there is absolutely noway to play or get the Legacy DLC for people with this issue.

@Modthryth – Yeah it seems you are having the exact same issue as I am.

If you get it to work, I’d be real interested in knowing how :stuck_out_tongue:

@Satoru – It is on EGS – thanks for the info. If it really is a bug on Epic’s end, I guess only option is to wait. That’s pretty bogus.


Played long time ago. Dont upgrade anything. in EGS i see game like Phoenix Point Year 1 edition. But at start in DLC enabled only living armor. Then click to the Blood and Titanium or Legacy of the Ancients send me to the store, where upgrade unavailable. In facebook where is message:

UPDATE: Issues with the Epic Games Store should be resolved at this point. Let us know if you encounter any other problems there!

We are aware of an issue that some users are experiencing upgrading to the Year One Edition within the Epic Games Store. We will provide an update when available and are working with Epic to resolve this issue as soon as possible.

is problem have status solved? Or is still in work?

1 Like

I signed up to these forums for this issue - on my PC I have PP Y1E with the blood/ancients add ons - and when I come to play the game on my Mac, which I want to do as I am sometimes on the roads, the DLC seems bugged as hell on the Epic game store - sometimes it says its not switched on, so I turn it on, and as soon as you go back to it it turns itself off, then sometimes it says its not available, and sometimes it says its on, so I launch the game and try and load my save game from the cloud that I played on the pc version - and it says I don’t have the DLC so can’t load the save game, what’s going on ?! this is Dec 10th 2020 I write this.

1 Like

I recently purchased the year one edition on EGS, and ran into this problem on my first attempt at playing the game. What solved it for me was to uninstall the 2nd DLC (right click game in library, manage content) and the reinstall it.