Very long loading time after BB5

I have very long loading times when I start up the game. The “Made with Unity” logo pops up, then the screen goes black for a long time, I’d estimate it somewhere between 10-20 minutes. After the initial load, there are no issues with loading times at all, and the game runs nice and smoothly. Never had the issue until BB5, and the problem persists regardless of graphics quality or screen mode with no significant difference in time spent.

Install it on SSD drive.

Thanks for the suggestion, but it already is on an SSD. Tried reinstalling it as well, but no change.

@ErikMcAwful same for everyone I’m afraid. I make coffee or wash-up during the lag time :sweat_smile:

It’ll be fixed when the full game comes out.

Thanks! I tried googling it, but as I found very few others who described any similar issues, I thought it could’ve been the game reacting weirdly to certain hardware types or something. I’ll just live with it for a couple of months, then. :slight_smile:

Could you please say what you mean with long load time? Edit: Sorry, got it 10-20 min.

I’ve tested it on 4 different drives, from hdd to nvme ssd.

The difference between sata ssd and nvme ssd are only few seconds and between fast nvme ssd and very fast nvme ssd are really really low. So it doesn’t scale that much at some point.

If you say it takes 1+ minute on your system with ssd it could be cpu or ram. What CPU and how much RAM you have?

I have tested it my selve on two desktop both Win 10

  1. CPU I7 3740k 16Gb DDR3 Samsung 512GB SSD (only initial lag after first startup of BB5) around 1min to start

  2. CPU R5 3600 32Gb DDR4 ADATA XPG GAMMIX S11 Pro, M.2 - 1TB around 30 sec

  3. Tested my work NTB with i7-8650U and 16GB DDR4, PM981 NVMe Samsung 512Gb = measured 53s to menu

So no idea about the huge delay

edit: add laptop results

Ok, I’ve done some additional testing on CPU.

I’ve set my Ryzen 3700X (65W TDP) to 35W - no chnge on loadtimes. ( cpu is too good :slight_smile: )
Set to 15W (around 500Mhz) - sorry I aborted, that could end in many mny minutes
Set to 25W (around 2500Mhz) - from 35 seconds to 55 seconds.

Low(er) CPU power definetly changes loadtimes to a multiple of its base time.

Windows power settings lets you set the max cpu percentage as well. Just a tip so you don’t have to mess with bios. I get my 4 ghz down to 800 MHz using that method.

My 4970 with 32 GB of ram loading off a crucial MX 500 takes less than a minute ( cold load).

Right, never used the Energy settings for that, I trust the BIOS more :wink:
And it not really complicated with the BIOS, just type one value to the max power target.

So not everyone has a long load time problem? I’ve heard so many reports of this that I thought it was a universal problem.

It’s odd as my rig has enough power to hack NASA; the only thing I lack is an SSD drive. It’s taking me an average of 5 minutes to load up. After that it’s all good.

No, not everyone. In most cases HDD and in some cases slow CPU users.

And I don’ t have a problem with 30-60 seconds, other games also takes that much time to load.

very long loading time here, too. not all the time, though.

ever since rev 0.5.48579 I’ve experienced this. I stopped trying to play in full screen mode because I thought it crashed - it got better when I started up in windowed mode, but now that I think about it, perhaps it just took too long for me to load and I thought it crashed.

today I started in windowed mode and thought “oh no, now it crashes in windowed mode, too”, but after reading this thread, I just waited about 7 minutes longer, and then it did start eventually.

It could be a slow cpu or low RAM (what hardware are you running on?). But surprisingly, low end SSDs can actually be only slightly faster than HDDs. It’s crazy. This occurs more on laptops where the drives end up thermal throttling or really cheap SSDs that run slow controllers and are often “DRAM-less” boards.

Without hardware specs, just spitballing.

Quick edit. It looks like the app loaded 12 GB of data off the drive but doesn’t seem to use it. App seems to actually only use 1.5 GB of RAM during the load.

Just ran into this, unfortunately, it doesn’t load at all. I have a very powerful system, I9, 1070 Nvidia, 64GB and game is running off M.2 SSD. Waited about 15 minutes before stopping it in Task Manager. CPU was running between 5-6% and game was only using 1.6GB ram.

Hello there, at what point did this start? after the game launcher?

I only had one CTD from clicking on the screen prior to the “Snapshot Games” logo appearing, but otherwise, after running a stopwatch to see what is what, here are the times I got.

46 seconds to Snapshot Games logo
54 seconds to Phoenix Point logo
1m 13 seconds to picture of planet Earth

One note - I had tried launching the game yesterday and it wouldn’t launch at all, and it was an issue with the Epic Games launcher, but, this was all prior to that mini-launcher app that asks for graphic options comes up. It did nothing for around 20 minutes, then I tried to sign in on Epic Games website and had a message saying “The service is unavailable”, and when I tried the Epic Games launcher itself it said “Your account has too many logins, please try again later” (paraphrasing here). In the end, I enabled 2-factor authentication, and will be launching Epic Games launcher first, as there is an option to open it "offline’ if there are issues with their servers. Perhaps there is something here that is causing the slowdowns - but let’s see what the developers say. :slight_smile:


Added: Ryzen 1700X - 16GB DDR4-2933mhz - 500gb Samsung EVO 960 M2 - W10 1903 - RTX2080

I don’t use Epic Store to launch the Game. I start the PhoenixPointWin64.exe and never had problems with it.

Do you watch the whole Intro (after the Snapshot Games company logo)? You can cancel it with a mouse click. I don’t know why it should take ~3 minutes on your machine.