Trying to get the pre-Alpha (Fixed)

Can’t download the game, got the email for the pre-alpha download but when I click the link all I get is a XML page that says Error access denied. Help?

Edit: Fixed VPN solved the issue

If you are using VPN or proxy, try disabling those temporarily. This helped me with the same problem.

I’m not using those though.

Well, the other advice I got was to keep trying and check if you’ve got more than one email with a download link. If you received multiple emails, then only one of the links is valid.

This is the only email I have associated with my paypal which I used to buy the game with.

I meant multiple email messages, not addresses.

I’ve only gotten the one email

That error isn’t on your end, if you cannot get past it even after waiting for a while and then trying again, please contact Xsolla directly at – we’ve had a few cases where apparently faulty links were accidentally sent out.

Point of clarification though, this is not a beta, this is a pre-alpha stage build to test out the very first steps towards the final game.

Ah well I did send them a ticket but haven’t gotten a reply yet.

There have been a number of glitches and the likes, it might well be that they are a bit swamped, plus in some countries, May 1st is actually a holiday – so maybe give it another day.

I know it can be frustrating to have to wait even longer on something you have been looking forward too, but sadly there’s nothing we can do on our end here.

same issue here, anybody have any additional information? tried contacting Xsola customer support, and they directed me to snapshot games customer support- after re-sending a broken link.

What exactly did they tell you we/the Snapshot employees could do for you?
Distribution is handled by Xsolla, and the only thing @UnstableVoltage might be able to clear up for you is wether or not you actually are supposed to have Backer Build access – but since they already sent you a link, they seem to think you do, I would guess.

Anyhow, maybe the bossman can shed some light on this, you could try sending him a private message.

@Genovafalls Xsolla are fully responsible for fulfilment. It is their system than generates the links and hosts the Back Build. We literally have no control or access over it.

Well then, the more you know i suppose. I will attempt to get back in touch with their support team again in the morning. I purchased the deluxe edition, which came with the chaos reborn bonus content, which they seem to believe is the only content i’ve purchased. I suppose i could ask them for a new download link tomorrow. I’ll see how it goes and update after. Wish me luck.

You can try a VPN it worked for me

Well this is just odd- before attempting to contact xsolla’s customer support again, i decided to try @Darkpheonix 's VPN fix, and it worked. I’m not sure what the VPN has to do with Xsolla’s website, or the download links, but it did the trick for both of us.

1 Like

Hm, that’s weird indeed, but thanks for posting your workaround – it might just help the next person.