The game breaks every time I close it

Yesterday I started a new game with the 1.7 patch. All DLCs are active. Everything was fine, I played through a few missions, saved and exited the game. Later, trying to start the game – it doesn’t work. Just the black screen, not even the first logo appears on the screen. Tried a few times, waited for 10-15 minutes, no success. I used the “Verify” option in EGS and suddenly it downloads 1.19GB more, after which the game launches just fine and I played a few more missions.

Today morning, trying to play again. The game launches but the game freezes when I try starting any tactical mission. Tried to start a few different missions on a global map, no effect. Verified the files and EGS downloaded another 1.7GB after which the game was working just fine.

Now the game won’t start again. Black screen shows for a few seconds and then the game just closes. Verified the files, now EGS downloads (very slowly) 1.68GB and I think it will be fine after that but just for 1 launch.

I don’t see anything similar on forums so I assume it might be just me but the game was working fine at 1.6.2. Any hints?

Here is how output_log.txt ends after the last unsuccessful attempt to launch the game:

Setting up 2 worker threads for Enlighten.
  Thread -> id: 4f58 -> priority: 1 
  Thread -> id: 7064 -> priority: 1 
[INFO] 176764 (3523,994): ====== GAME STOPPED - 07.07.2020 10:10:50 ======
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug.bindings.h Line: 45)

  at (wrapper managed-to-native) UnityEngine.Component.GetComponentFastPath(UnityEngine.Component,System.Type,intptr)
  at UnityEngine.Component.GetComponent[T] () [0x00020] in <a35d771e78bd4d75a6f3aedeaad4d1ed>:0 
  at PhoenixPoint.Geoscape.Levels.GeoFaction.UnsubscribeForSite (PhoenixPoint.Geoscape.Entities.GeoSite site) [0x00040] in <e3e491a59b9c407eb19de28d2442a7b2>:0 
  at PhoenixPoint.Geoscape.Levels.GeoFaction.OnLevelEnd () [0x000e9] in <e3e491a59b9c407eb19de28d2442a7b2>:0 
  at PhoenixPoint.Geoscape.Levels.GeoLevelController+<>c.<OnLevelEnd>b__131_0 (PhoenixPoint.Geoscape.Levels.GeoFaction f) [0x00000] in <e3e491a59b9c407eb19de28d2442a7b2>:0 
  at Base.Global.ForEach[T] (System.Collections.Generic.IList`1[T] list, System.Action`1[T] action) [0x00010] in <e3e491a59b9c407eb19de28d2442a7b2>:0 
  at PhoenixPoint.Geoscape.Levels.GeoLevelController.OnLevelEnd () [0x00099] in <e3e491a59b9c407eb19de28d2442a7b2>:0 
  at PhoenixPoint.Geoscape.Levels.GeoLevelController.OnLevelStateChanged (Base.Levels.Level level, Base.Levels.Level+State prevState, Base.Levels.Level+State state) [0x00036] in <e3e491a59b9c407eb19de28d2442a7b2>:0 
  at Base.Levels.Level.SetState (Base.Levels.Level+State state) [0x0005b] in <e3e491a59b9c407eb19de28d2442a7b2>:0 
  at Base.Levels.Level.Done () [0x00000] in <e3e491a59b9c407eb19de28d2442a7b2>:0 
  at Base.Defs.DefineableBehavior.OnDestroy () [0x00008] in <e3e491a59b9c407eb19de28d2442a7b2>:0 
(Filename: <a35d771e78bd4d75a6f3aedeaad4d1ed> Line: 0)

[INFO] 176764 (3523,994): Mist resources not unloaded properly - unloading OnDestroy
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug.bindings.h Line: 45)

Got this for my issue that was one of the problems you encountered.
Aparently you did the right thing, however it somehow deletes the files for you?
I suggest you alt + F4 out of the game after the download and works fine part, to prevent that happening. I try that one too. Except I got a shitty net and downloading those amounts is a nono for me.

"Hi there,

I’m Eric on the Community team here at Snapshot Games for Phoenix Point, and I believe you may have encountered a bug in our game that our developers were investigating. It sounds like your installation may be corrupt, and you may need to reinstall or verify the game again. Once you do that, it should be up and running again.

Let me know if you need more help with that matter, and thanks again for sharing your feedback!