Screen freezes, but game still running

Hello, wondering if someone found a solution - I have a problem that the game screen constantly freezes, both in geoscape and battle view, it is random, it can happen in the first few minutes of play or an hour later, but it always does. Looks like a graphics issue, as the sound is still on, and the activities in the background are still running, for example if I see the button for fire, can click and and can hear the firing. The only way to resolve it is a restart of the game. I tried multiple things - logged as admin, shut down epic store, before starting the game, my drivers are up-to-date (Nvidia - GTX1060), I have decent specs (16GB RAM + i5 Intel processor). Tried also re-installing both the game and the epic stores client. Running it on Windows 10 OS.

Hopefully someone can help, as the game is awesome!

Lower game settings to High, because at Ultra it can get stuck for me as well (I too have i5 + 1060). Probably GPU or CPU (or they both) have some problem with parts of the data and engine can’t handle some exceptions thrown at him. With setting at High I have never experienced freeze or hang.

I hope that Snapshot will decide to choose different engine for sequel/prequel.

Thx for the hint, I did lower them to medium even, but still freezing, will see if low does the trick…

Interesting. And how big page file do you have? Maybe increase its size?

Do you have overclocked some of the PC components? Try to set reference values not retail ones.

1 Like

Yep, still freezes, nothing else is on as far as applications go, no overclocking done from me, which page file, not sure I understand your point?

in Windows you can set size of “page file” manually or you can leave it for system to configure. System can sometimes screw it with automatic value, so it is better to set it manually. For example to 16 GB. You will need to check some manual on youtube how to do that.

You can also check this thread and install redistributables:

Thx, changed the page file to 16GB, will see if this and the Microsoft redistributable are making a change.

Just to update, installed the redistributible, and increased the page file, brought back the settings to medium, still freezes, so I guess something else, oh well, will hope for someone from the dev team to notice this…hopefully they will make a fix. Thx for all your advice Yokes!

No problem, tried to help.

Shooting in the dark, but what are the temps on your GPU?

Looking at them now, with the app frozen, it got to 60 C, power and core usage was at the top of the game, before it froze at 50-60% utilization, so not an expert here, but it doesn’t seem to be that bad…now as it froze, the game is actually running temp is at 40 C and utilization is at close to 0.

Issue SOLVED! - The culprit was one of my HDDs, it is close to end of life and although the game is NOT installed on it, it seems that overall PC performance is suffering from it. Once I disabled it, the game is running without a glitch - tested it for several hours now, different things being done, all good. So HW problem!


Hello again, I guess I spoke too soon, so after some time playing, the freeze issues came back in force…now the whole system is basically useless, after some struggling, I even re-installed windows, had to re-install several times the Geforce drivers (up-to-date), still same problems, the whole GPU is failing this time, not just the freeze itself, it seems the game somehow is slowly destroying the card, and by looking on the web it is the same model - GTX 1060 with 6GB…very strange, as it seems multiple gamers with that card, seem to have the same problems, which makes the game vritually unplayable. Will try some more and will have to give up, and the story is sooo great. Anyway, just wanted to share, hopefully this can reach someone from the developers.

interesting as I also have 1060 and no problems for me unless I try to play on Ultra settings. Very High settings never crash.

(SOLVED)Thx for the reply, as I didn’t let it go I think I finallt found out what was wrong - I had a failing PSU, it turned up it was 8 years old and even though was working, seems the Ws were not as written on the box…just replaced it, and now much, much better, crossing my fingers that during all those tests I didn’t screw up my GPU. We can close this topic.