Reloading stuck at one ammo

Reloading the rifle only gives up to 1 ammo even on second turn reloading it is still stuck at one at most. Other weapons appear to be working fine just the rifle bugs out during the missions

After reloading, the rifle only fires one round on reaction shots as well.

As an addendum, for an assault:

I reloaded, and gained one “shot”.
When that “shot” was used, it was a reaction, and it only fired one round. I reloaded again, and it worked okay.

Can you describe more what you did before that? It never happened to me and I try to find different bugs.

I’ll keep adding relevant information.
For clarification: volley = bar of ammo in the indicator
round = actual shot fired

I had thought before that I’d simply reloaded when there was one volley left in the mag, then the Assault took the swapped-out one-round mag and reinserted it. In this case, after having one volley left, I killed an egg, to be sure the magazine was completely empty. After reloading my FIRST TIME ON THE MAP it only had one volley in the magazine. This last time, I had enough AP, so I IMMEDIATELY reloaded again. That gave me a full magazine with full volleys.

In the past, when this happened, the reloaded magazine that indicated one volley would actually only fire one round, whether it was a directed fire action or a return fire.

I’m currently playing on a nest map, but this has happened on other maps too. It’s always the FIRST reload, so if you’re in a sandbox kind of config, that may pose a challenge to creating the right circumstances.

So, this happened again in the same map. I had gotten down to one volley left in the Assault’s weapon. I reloaded (this would be the third reload–first went to a one-round volley remaining, second was as advertised, third was again a one-round volley), and I tried to use rapid clearance, without realizing I’d only gotten one volley from the reload. I used it point-blank, and shot only one round. Reaction fire and everything else proc’ed/triggered normally, as far as I could tell.

I swear, you seem to be a magnet for odd bugs, man!

I’ll see if I can get it to reproduce as well.

Wondering if game is saving non-empty mags? And possibly, if you’re not visiting base in between, those mags aren’t reloading? Only thing I can think of that would be a non-bug.

Will try to update if I can get it to trigger.

I don’t know. I can’t replicate that. :stuck_out_tongue: And I want to play the game already, because I’ve been chasing bugs for 3 weeks after the work - I suppose it is enough. Probably I will upload them today near 5 pm UTC. (I wonder how many of them did the players found).

I have had this happen once or twice with the firecats and assault rifles. You reload an empty mag with a new one. The new one, only shows as one round in the mag. Fire that one round and you are empty again.

I reported it with F12. Seems that when it happens once in a mission, it will happen several times. I never paid enough attention if it was in the same
map type.

For Grenade Launcher it is typical. You reload only one grenade with each hit of Reload ability. But with Assault Rifle? I always get full mag.

Can you write how many magazines do you carry when you try to reload and this happens? And how many burst you have left before reloading? Maybe there is some mix of current and spare ammo which brake reload algorithm?

I usually have one spare magazine and always reload when current magazine is empty, so maybe this is why I didn’t spot that.

Since I have each soldier carrying 3 different weapons, except for my snipers, I haven’t actually needed to reload any of the weapons before the mission is over. Does make things a bit more interesting when the soldiers are down to pistols only

NJ Pistols or PX Pistols? Becase latter are vast superior to the former just because of the accuracy. :wink:

as soon as I get a spare PX pistol, I use it.

For me, it happens only after performing the “special attack” with the heavy guy. The one where you select the first and last target and then he empties the whole magazine. After doing this any reload will just load 1 bullet and no magazines are removed from the inventory. I’ve got 2 mags in the inventory when this happens.

So we come to conclusion that you need to have at least 2 magazines in backpack for this bug to happen? :slight_smile: