Patch failed - launch unsuccesfull ...!

… for real?

Works for me. What exactly is the problem?

It didn’t work for me too… killing an umbra freezes the game… HOTFIX - v. Necronomicon 1.7.2 - 01/10/2020

The fix is that Arthron Umbras do not appear anymore if you do not have DLC2 activated. So if you have a save from inside tactical map it will still hang. You need to restart the mission.

The patch will not install and then game fails to launch …
Just like that.

Try to verify the game in Epic Games Launcher. Eventually, reinstall.

You can also try to run the game from the .exe file on your PC (without using Epic Games Launcher). Go to where your game is installed and run .exe. In my case, it is D: Program Files\Epic Games\Phoenix Point\ PhoenixPointwin64.exe

How about saved games/progress?

Currently mid Marts and would hate to lose it all.

do you mean leaving the mission and entering it again? restarting with the ESC button does not work…

Load the autosave, it should be direct before the mission.
I assume, that restart in a mission will not work, because you get the same enemies at same positions. When an Arthron Umbra was there before the patch then he will also be there after the patch. Again, only my assumption …

1 Like

it makes sense

After exploration none of the options/choices work, game freezes. In the NJ starter mission after shooting enemy unit game freezes … great patch.

PhoenixPointwin64.exe does not work. Never has. I´ve tried that one earlier on.

No option to verify in Epic …

Epic wont even let me uninstall the game … Just broken.

Played a few hours before your latest patch, when I went back to start the game up again nothing works …

Here you go:

Klick for picture

3 points down from “Verify” …

1 Like

Thank you for trying to help, but it is not there …

Did you try this right after it crashed?
Under “Phoenix Point” it says “Resume”, normally it should say “Launch”. Looks for me that the launcher tries to restart the game after a crash, maybe. If that doesn’t go away by itself, then try to restart the Epic launcher or the whole PC and look again.

Don´t remember the exact order I tried different things, but have restarted everything. Even left the computer shut down for several hours - still the same.

I can´t even uninstall the game.

Have contacted Epic as it might be on their part, but it happened as result of new patch coming in.

Have even bought a cheep-ish game on Epic to see if I could download and play that - works fine … so …

Then I don’t know what to do here either.

In addition to Epic support, you can also contact snapshot support ( Perhaps in this case direct contact is the better way than here via the forum.

Thank you for your help and suggestion on Snapshot support.