Patch 0.3.32990


#1
  • Fixed a game hang after using the stun rod with the last active soldier.
  • Fixed an issue where destroying an enemy’s body part with Overwatch/Return Fire would cause the game to hang.
  • Fixed an issue where Crabmen shot the walls in front of them with their grenade arms.
  • Fixed an issue where the Queen caused the game to hang while evaluating her movement options.
  • Fixed a bug preventing the game from launching if the user had a corrupted savegame file.
  • Fixed an issue where a unit still had the overwatch status even when their weapon was destroyed.
  • Fixed an issue where enemies tried to walk to unavailable locations and this caused the game to hang.
  • Fixed an issue where the Armadillo’s sounds would play continuously if you moved only a few tiles with the vehicle.
  • Fixed an issue where the Heavy couldn’t evacuate via the Exit Zone after using the Jet Jump ability.
  • Fixed an issue where the player would see empty unrevealed sites on the Geoscape after returning from a Scavenging mission.
  • Fixed an issue where the keybind for the Overwatch (“Y”) didn’t work for the PDW or the Sniper’s Pistol.
  • Fixed an issue where the item information panel in the Edit Equipment screen was obscured by some of the buttons.

Build just updated
pinned #2

#3

So mostly game crashing bugs. Nice.


#4

Yay! This should cut down on the hanging issues I think some folks still reported having :o


#5

Unfortunately I had crash yesterday. Last crab had his turn and did nothing. Noone was overwatching. Crab had full health. Hard to say what happened. But his turn has never ended. Had to Alt+F4 the game. Maybe some path algorithm get in infinite loop. And this almost never occurred to me. Btw I will update my bug list today or tomorrow, will add info what was fixed etc. :wink:


#6

Latest patch is much more stable that the previous, went most of the day without a lock up. BUT: Haven defense, was down to 1 last alien. Searched all buildings finally found him. Team was split up so I pulled back then during the Alien turn it locked up on me.

PS: oh damn is it boring looking for that last alien, can something be done to speed up the process.


#7

There seems to be an issue with an isolated alien not doing anything. Possibly the patrol system is broken.


#8

Yeah, the last time I played the demo I got a little frustrated with hunting down one last alien on a haven defense mission. Maybe when you get the aliens down to one or two units they’ll panic and automatically reveal themselves, to make it easier to hunt them down?


#9

And I liked it. Maps are not so big currently so hunting down that one last is not so big problem. :slight_smile: But if there will be more complex maps your request should have a solution. But hey there probably will be some scanners, UI indicators to help you with that hunt.


#10

There could be some kind of grenades that make a noise that attracts the aliens


#11

they could make sound of little kittens (noone can resist them)… or some horny crab-woman/man?


#12

Perhaps like Dune sandworm, a Thumper to attrack them :thinking:


#13

this is only windows, yes? mac version out yet?
thank you for great work on a to-be-fantastic game!


#14

The Mac version has been updated, but you will need to redownload it of course.


#15

I just around now to update the game, but the launcher “crashes” (it just closes itself) when trying to install the update. It downloads the update (P2P or not), and then it closes itself a split second later.


#16

Woohoo! go Phoenix Point producers! good job!


#17

How do you implement a patch? DO you have to re-download the entire game (on Mac)?

I have uninstalled and had to download the game 4 times to get it to work, after the alien base games would not load. THey still wont load, but now I have other hang problems too.


#18

on Mac you currently have to redownload the entire game. A Launcher for Mac is on the way though!


#19

Thanks. Any idea why the alien base games won’t load for me? It seems other people can play them just fine, but my game experience is severely limited as I cannot stem the alien tide (pun intended), as I cannot attack alien bases.

Like mentioned before, I have uninstalled nad re-downloaded the game several times, ut this seems to have causes me more problems than it solved.


#20

no idea. I just know that it is a known issue for several people