No aliens left, combat doesn't end

A scavenging mission, killed all the aliens I could find, but couldn’t leave the site. Ending my turn immediately started another. I have a save game from that state if anyone’s interested, also a couple more from the same scavenging mission before it all went Hotel California.


I think this is one of the BB bugs.

~ and type “win” in the command line will at least let you continue the game.


Yes DazzD is correct you need to type “win” in the command console to end the mission. However, this only works for a while then you don’t get past even one round as it gets more complicated. What I have noticed is that the AI stalls, at first it just starts to slow down (as the numbers increase) then it just stops especially when your winning! I think there is something fundamentally wrong in the AI at this point, there is so much to work out it can not deal with complicated stats or high level numbers of aliens. At the start when the numbers are small it flies though like a dream, but as you get more powerful soldiers and equipment the calculations get more complex and then add 30+ aliens to the mix and it just gives up! It finally gets to the point were you get to move your men just once and then it is all over and you need to type win to get out of it, very frustrating as it is just starting to get interesting…

Yup, that’s what I did after trying to be certain there weren’t any
critters cowering in a corner. I was only reporting it because I had a
convenient saved game if they wanted it, and because, often, it’s
possible to have multiple causes of the same error.

I have found that once you get well into double figures of Pandorans,
their turns can take two or three minutes to complete. But I’m assuming
that’s at least in part due to the AI still being debug code so once
they remove diagnostics and compile an optimised release it should pep
up a bit.

You do know you can press “F12” and it sends a screen shot, saved game and debug info and the line of code it stopped at right? You don’t need to send saved games F12 will do everything for you…:slight_smile:

No, I didn’t. Thanks for that.

Tried using F12, neat system, but shame about the Upload error: An
exception occurred during a WebClient request.
errors I’ve got when
I’ve tried to use it. Is there another hotkey I can press to report
errors with the error reporting :slight_smile:

Not that I know of sorry!

how many saves do you have? Apparently having too many can prevent the upload from working properly as it is trying to upload all of them

Dunno, haven’t checked, but probably 10-20. I tend to save a lot for
crash avoidance, then periodically have a clean out. Why on earth would
it try to upload all the saves? That’s barking. Why not create a save
for the game at the point F12 is pressed?

Anyway, I’ll try pruning them and see if it makes a difference. Thanks
for the suggestion.

so they can see how the data has changed since the last save is my guess. Also it does create a snapshot of the data when you file the bug.