Need to click a lot of times to start the game


I have just managed to get into the backers build. I struggled to get in the main menu but discovered that it worked when left-clicking repetitively. Placebo effect?

I’m still downloading, so I cannot verify it for myself yet, but you try checking to following things:

  • Are there any other processes running (in the background) that might steal focus from the game window, which would be returned by clicking inside it?

  • Are there maybe movies like intros attempting to play but not playing correctly and you are skipping them by clicking?

I think it’s an issue with your virus protector, Norton went full “we should kill this new unknown file” when I downloaded it and now it has crashed, after which the .EXE worked much better. I got the splash screens with 4 fps and then blackness before, now 60 fps and in main menu. I expect we’ll need to set specific exceptions in our antivirus for now.

I checked that. My anti-virus has added Phoenix Point to the list of games so it’s not “fighting it”.

Well, sometimes I too deal with the same issue. Like, last time when I had purchased Call of Duty World War 2 gamelay from online PC gaming store. I was also dealing with similar issue by clicking a lot of times to start the game. Then later on, I had found out these details and checked out the minimum and maximum requirements of the game and I had found out that the RAM it should be 12 GB. Later on I had again reinstalled it and then it works. I think you shoud check out the requirements of the game.

It is actually my plan - I currently experience the problem (annoyance more than problem as I can actually play the game) on my work laptop. I will download it on my gaming laptop and see if the problem disappears.

Ok seems a bit better with my gaming laptop. If I click too often though it will crash the game before the Snapshot games appears.