Crash on start up

Get the game title intro for Phoenix point but then gives a not responding. Game is also taking up 8 gigs of ram not sure if that was intended or not. But as it stands cant get to the main menu assistance would be much appreciated.
System is, 1080, R1700X, 16 DDR4
Need anymore information please let me know, thanks.

Same here :frowning: Got a i7-5820K cpu, 16 GB DDR4, 970 GTX

I’ve tried this on my main and get the Unity, then SnapShot splash screen, after that nothing. Main system is running i7-3770, 32GB ram, Asus GTX670 card.

Now I tried this on my Surface Pro 4 which is an i5, 8GB ram and I can get to the game menu and into the game, just very choppy and slow for everything.

Tried this on my Lenovo Y50 which is also running an i7, I can get the main screen and choose a game. Just takes a minute or two to get fully into the game. Response is much better.

I just can’t get this to run on my main system, it never ever gets to the accept or unaccept user agreement screen.

So if it’s not the i7 causing it, how much RAM does the Lenovo have, and what are the graphics adapters for the Surface 4 Pro and the Lenovo respectively?


My Lenovo Y50, which is a laptop, only has 8 GB ram and uses the Intel HD Graphics 4600 and Nvidia GTX 860M. The Y50 is not as powerful of a system as my main desktop. The Y50 processor is slower than my main.

My main just has the NVidia GTX670 which has 4GB vid ram, but I have 32GB of ram, I’m not using page files though since I have plenty of ram.

Then there’s a possible reason:
Try enabling page file for your main system… both other systems likely have it enabled, both other systems have much less RAM, the only one it doesn’t run on is the one with lots of RAM and no page file it seems.

1 Like

Well, I haven’t used page files since I built this system 5 years ago. I run Skyrim, Fallout 4, Stellaris, Polaris sector and many other games with no problems.

I just tried the game again and after 5 minutes, finally got the user agreement screen to popup, but crashed when I tried to accept or click anywhere else on the screen. The music was choppy, so from past experience with alpha and beta of other games, the audio might be a problem. Will try again later, but have to go. Good luck.

Hi, All,

Instructions are a bit spotty - but extracted the game in to a folder C:\Programs (X86), then executed the Phoenix Point Executable. The Options screen came up so accepted the settings and saw the Unity screen and for the last twenty minutes have been looking at a rather fetching purple screen…:scream:
According to Task Manager it’s using 0.2% processor time and 1,270.6 mb of RAM.
System spec is:
i5 3470 @ 3.2 GHz, 8 GB RAM, 12 GB Virtual RAM, GTX 660, 2 TB Main Drive, 3 TB external, 1 TB storage drive. Just installed the latest Windows 10 update 1803 - so whether that’s having an affect or not, I couldn’t say. Graphics drivers are the latest offical ones, whilst the MOBO drivers are the latest MSI ones.
Even tried running as Administrator - but doesn’t seem to make any difference.
Any suggestions would be gratefully received.
All the best,

The game runs perfectly fine for me, startup takes a bit long, but other than that so far runs without issues.

Core i7 8700K, 32 GB DDR4-3200 RAM, GTX 970, Win 10 Pro

Put the folder in Program Files (x86) and run it in windowed mode. Got a application run warning from my anti virus program. Allowed it to run and it works fine now

Same issue here.
3840x2160 980gtx 4g / 32gb 2666mhz ram / win10 pro 1803 (insider preview) / Nvidia 397.31

neither running exe in \program files (x86)\ or as administrator or in windowed mode or in lower res made a difference.

App runs, Unity quality settings appear, once past that it’s evident the framerate drops incredibly (in 4k it’s about 1-2fps as the logos fade in/out) both logos render / fade out then black, for god knows how long. Also it shows the GPU running at 100% (red) in Task Manager and the game using about 4gig of ram. My guess is that it’s having an awful time processing something and will eventually reach the game but that could be a long time away.

Will try some trickery…

AH OK. yeah checked closer, it may be selecting the wrong GPU, it’s using onboard for some bizarre reason i guess, because my Nvidia GPU is fine on Performance profile, but GPU shows 100% usage in the task manager preview and my cpu is maxed across all cores (i7-6700K 4GHZ).

Ah yep confirmed; in the Unity log it shows it’s selected the Microsoft Basic Render Driver, so that’s our beasty. Will post the fix.

1 Like

Ok, started with a simple reboot, now it’s loading fine. Things have been a bit whacky since the 1803 windows update though, so may have nothing to do with PP.

Same here, cannot get to any menu

1st time computer completely frozen in black screen after PP logo, had to hard restart -> reboot doesn’t help
2nd and onwards always crashes to Windows after Unity logo

No option to select different GPU (don’t think I have any), AMD R9 390
PP only gets to 570MB at that point, so not a lack of memory; enough of drive space too
Windowed mode didn’t help, Run as Admin didn’t help

Can’t find any log files to help with this (either by “Phoenix Point”, “PhoenixPoint” or “Snapshot …”)

Well, after rebooting my system and trying again, it finally started up. Got to the user agreement screen, then to the main menu and finally into one of the games. It didn’t take as long to start up after rebooting the computer though. So for others, try rebooting and starting the game and see if it doesn’t crash. I also suggest you just wait patiently once you start it, it could take a few moments to 3 to 5 minutes to start up.

1 Like

Hi, i had the same… Game not responding after intro. Set up the pagefile to min 2GB and max 4GB and it worked as a charm. Only thing is that after the initial loading screen i heard the muaic but had a black screen… Hit ESC and the license agreement appeared and the game started up.
Thanks for the tip.
Windows 10 Pro N
Intel i3 7020U 2,3 GHz
8 GB Ram
255 GB SSD
Intel HD Graphics 620
nVidia GeForce MX130 2GB GDDR5