Launcher window disappears but launcher.exe is still running


#1

Hi,
I am wondering if anyone has the same problem. I bought the luxury digital edition of phoenix point. Downloaded from the link in the email last November. It was working fine.

It stopped updating properly so I have applied all the suggestion by this topic.
After restarting, I clicked update, and when the progress bar starts loading up to something named NaN%, the launcher window disappears. When I try clicking the snapshot games icon in the tray, the icon disappears. So naturally, I thought the launcher crashed. When I restarted the launcher as administrator, a pop-up saying an instance of the launcher is already running. I checked the windows task manager, and the it was, launcher.exe is running. But no launcher window to be seen. If I end the process, I can restart the launcher, but the same thing happens.

I have been waiting for new updates on how to remedy this as I have noticed a number of players seem to have solved this problem. I am running phoenix point on windows 7. Could this be a problem?

Thank you.


#2

Try to restart comp if it doesn’t work. Uninstall and reinstall the game and launcher. I had the same problem.


#3

restart your computer, it worked for me.


#4

Okay. I tried this option…and it works. Thanks.


#5

Good, no problem. Glad it worked.