Incomplete Installation?

Greetings, something very bizzare is happening. I have pre-purchased the standard edition of the game. Today at 5:30 PM EST I tried installing it and it showed that it was completed within two minutes; my internet is not that fast. When I click to launch the game, the phoenix content directory pops up and nothing else happens. There is nothing in the directory except the soundtracks from what I can tell (C:\Program Files\Epic Games\PhoenixPointContent). The whole directory is only half a gig big. The Epic Client shows that the size of the game is 27B.

These are the contents of the directory:
.egstore (dir)
Backer Build OST (dir)
Mokushi - AM3 (dir)
Phoenix Point OST (dir)
opendir.bat (bat file)
README_Album.txt (txt file)
README_Soundtrack.txt (txt file)

I tried uninstalling and re-installing, verifying the game, runing Epic as admin, nothing worked.
What the heck is going on?

Intel i5-3570, GeForce GTX 1080, 16GB memory, Windows 10 Pro

Please advise.

That’s happened to me as well… Is there any solution for this guys?

You are downloading wrong package. Phoenix Point Content are goodies.

Look for simply: Phoenix Point.

thanks man! i made the same mistake!

Jeezus antichrist! I completely missed it, thanks man.

It’s sort of strange how the content is treated as a game itself. I think that is a bit of a cock-up at Epic.

The content which is just bells and whistles is reporting 6 DLC. The game itself reporting 5 DLC. Very confusing.