Game keeps freezing a lot

lately the game keeps freezing a lot…
it started after i “added infiltrators to my army roster”…that is, it was working fine before that…some glitches with save/load, but that was it.
now, i have to keep saving turn for turn hoping it wouldn’t freeze . i end my ture, enemies work fine, then come the “residents”. sometime it freezes here and sometimes right before i get my turn (you hear the audio signal for the beginning of my next turn and it stops there). i can still “surf the map”, and animation isn’t frozen, it just stays like that until i “end task”…

anyone else had a glitch like that?

1 Like

confirm. got the same issue

1 Like

mine freezes, after recruiting and add NJ technican and he successfully make first hit. cant even press f12 to report the bug. research on new jericho equipment never happened, so i had him using ar1 rifle.


1 Like

haven’t had probs w technician…so far i’ve had anu priest and 'zerker, NJ tech, and SYND infiltrator…and only started having trouble when i had infideltrators…
i tried now to make a team w no infis…left them in base…and had lesser trouble, but veeery little (like it didn’t freeze every turn, just once per deployment…lol)

Yes. can confirm. Some one said there was some hot fixes last week, if so this started happening after those.

i can confirm freezing, too. But i dont have this problem during a battle, it happens after a battle. Actuall, if i do another one, it happens always. i tried 3 different locations for a battle. After each one, the game freezes and didn’t load the “loot-screen”. If i load the “auto-save”, i’m stuck in the same screen… i reportet it. Sometimes it happens the same thing, on a savegame directly before a battle :frowning:

Does the frozen screen look like this?

This is killing me with re-loading save games.

  • A

nope. it is in tactical battle mode.

hmm…new glitch. tried to go to main menu from combat and it froze same as usual…nice

Nowadays i have this freeze on every combat, usually after sirens move, but sometimes on civilians turn too. I have sent F12 reports on that and will keep sending them, and suggest everyone do the same.

Yes, that is the same freezing, like i have it after on a next battle :frowning: So i stoped playing this BB, to dont waste my time :confused:

dunno if they did something, but the game hasn’t been freezing much lately, though i had another interesting bug. at a point both my research and manufacture froze, and entering a base did not heal/rest my troops…anyone else had this?
it started when i had both SYND and NJ at 50+% and i just finished researching tranq. sniper (adv. paralysis thingies…sniper and hand grenade).

I can’t speak for a research link, but did you accidentally power down the facility that rests your men? Are you overcomitted for power and it automatically powered down that facility?

  • A

i know about that…and no. i also went to my second base, and still nada…also, yesterday all was fine and had no problems, until i went to do the Firebird mission, and it froze…lol

all right…i dunno if what i write next has any bearing on anything, but…i haven’t had a crash for an entire day now. maybe snapshot fixed it, maybe not…
i’ve been repeating a certain process, so i would like to ask y’all for feedback…here goes:
in missions: every turn, starting from 1st i do this - go to save game > delete previous mission save > save game (without renaming the save)…rinse-repeat each turn
in geoscape: same…delete old save and save anew (again without changing the save name)

i only use 2 saves, 1 for geoscape, 1 for deployment missions…so far so good…even done the “firebird mission” without probs.
also, i decided NOT to upgrade generators, just in case…will post again if anything new happens

My game keeps freezing from the 2nd mission while in tactical mode…Come on, i thought they had these things ironed out by now :frowning:

No new recruits, a sniper, an assault and a heavy in a Scarab (not the start of a joke!) game freezes and have to alt/control/delete to get out of game. Seems to be a tactical bug.

Something to do with when zooming in to either shoot or choose the target. Checked temps, RAM usage and CPU usage, all within normal parameters so this must be a coding bug…How didn’t noone notice this? They’ve been working on the game for years.

Im having the same problem. It freezes up when trying to shoot the spawner at the hive mission. Every time. Have tried it 4-5 times, same thing. Can’t move on beyond that point in story, so im stuck as to know what to do.

Well restarted a whole new game. Still freezing on me, a different mission, but the same one repeating. They always seem to be missions that are important to progressing. So i feel stuck again. Hope they fix this or many will just not be able to play.

Nope, depends on what screen your in. If a mission that’s the freeze you get that or whatever, etc.