Download corrupting? Consistent errors on extraction + game doesn't work right

I believe that the zipfiles are being corrupted during the download… I get consistent (each time I try to unzip them, and the same errors in the same places on those files) but different (for each downloaded zip file) errors. I’m using 7-zip and it’s a combination of CRC and data errors. I’ve also tried downloading to and unzipping onto multiple drives to rule that out as well, and from 2 different browser (Chrome and Firefox).

Example screenshot from 3 different instances of the zip file attached. And these errors are consistent each time I try to unzip that file, though you’ll note that the errors are different from file to file.

Beyond that… I cannot get past the license agreement page, probably because of the corrupted zip… Specifically, the whole thing slows to a tremendous crawl (I can tell that from trying to scroll down and read) and none of the buttons have the proper texture. (they’re all just white, specifically). I’ve tried this in both windowed and fullscreen modes. I’m running a 1080GTX, so that shouldn’t be the issue.

Any thoughts would be appreciated.

Have you tried unzipping the file with the regular Windows unzip function?

I did not encounter any such issues, I do however have an idea that might help, as I did encounter another very weird issue with a different download the other day:

When have you last updated 7Zip?

I hadn’t, for a very long time, what with having gotten used to auto updates everywhere, but 7Zip does not automatically stay updated at all – and just the other day, downloading a mod for another game, I had the weirdest and inexplicable issues with the archive being 712 MBs heavy, but the contents only “weighing in” at 13 MB.

So please try and update 7Zip to the newest version first, as in my case this fixed all issues and the very same archive suddenly worked perfectly.

As far as the performance issues you describe are concerned, I also do not have those, so I cannot suggest any solutions there I’m afraid.

Windows regular unzip function gives errors on the same files.

I was running a 7-zip from 2016… just updated to the newest, but unfortunately, still getting the same errors in the same places.

Thanks for the feedback – shame, but then it almost appears like an issue on your end rather than the download itself, as that should be corrupted for everyone if the source file were indeed corrupted.

How exactly do you download it, with which Browser, and do you use any kind of external download manager app?

Hey, just a thought. My computer threw a bit of a fit when I downloaded it. Every antivirus software I had was trying to quarantine the game, haha. So, it might be worth checking to see if your antivirus software is deleting part of the download before you run it.

1 Like

Looks like it’s some kind of issue with Firefox Quantam 59.0.2 (64-bit). I downloaded it a 4th time, using Chrome this time, and it unzipped perfectly. I had started a chrome download earlier but cancelled it. Sorry – thought I’d tried that as well before posting. I will try once more with firefox just to confirm… and firefox still gives the errors in the zip.

So… Chrome is good, firefox is bad… apparently.


Thanks for providing feedback on your … workaround I guess.
I’m using 59.0.2 myself at the moment, and the download worked just fine – but speaking of Firefox versions and downloads, there is an update available.

I don’t know why one browser would work and another would not. Downloading to different drives and all that. Doesn’t make a lot of sense, but there you go.