Save Game Corruption


Firstly I’d just like to say that I’m absolutely loving Phoenix Point. This game is HARDCORE old school X-COM, just the way I love it.

Anyways. Everything was going smoothly (besides some occasional bugs like not being able to place turrets again after picking them up), until tonight when I went to do a Haven protection mission.

One of the alien enemies is that MASSIVE giant bug thing, and I’ve fought 2 previously and had no issues at all, but on this one mission, if I save after that alien is killed then it corrupts the save and gives me an error message:

“An error has occurred while loading the game level.”

If I attempt to load any save after that error occurs, then the game goes into a loading loop and never loads and I have to close the game via task manager.

I’ve tried:

  • Creating multiple saves after I kill it. Same result on all of them.
  • Loading an earlier save from the Geoscape and trying again.

As I’m the save scumming sort, I like to save and load a fair bit, so not being able to do so is quite annoying. Double so, since it bugs the game up and I have to close it.