Cant load saved game

I’ve the recent build of the game (I think 0.5) after couple of hours of play I’ve saved the game during a fight.
I’ve tried to load the game using the continue button in the main menu without success and, I’ve tried to load it manually through the saved game tab.

In both cases I’ve tried it several times and waited around 10 minutes.

What can I do? Is there a way to fix it?

I’m having a very similar issue, although I’ve only encountered it on one map, and I seem to be encountering this issue a whole lot on this map, along with the enemy turn not ending properly. Not sure if those two bugs are related.

The map I’m getting it on is the bunker raid against Tusk (the one with the underground 2 floor base).

This is a known bug, I believe. I’ve had a similar issue, and simply had to abandon that campaign.

Bear in mind, this is just a Backer Build, so it is a WIP rather than a polished version of the final game that will be released on Dec 3rd. As such, it has its problems, of which this is one.

It’s not on the list of known bugs. There’s a similar one for the game freezing on the tactical map but I think that’s different (although some of my encounters may indicate it’s related). Besides, other than just playing around with the game and having a bit of fun, we are looking for bugs so they will be fixed by go live.