BUG report: High CPU use, inability to get past initial loading black screen


i7-3770s, 24 GB ram, GTX 1080, SSD, Mouse/Keyboard

EDIT: Video resolution for my system is 3840x2160 UHD 4K, three monitors side by side hooked to the system, running Windows 10 Pro, fully updated and current. no anti virus installed as this is also one of 3 systems I use for alpha testing for NDA projects I am part of for other major game titles in development.

On attempt to load and run the game, I get a slide show through the first few credits before things hang at a black screen and do not proceed further.

System shows CPU bouncing all 8 cores of the CPU from 50% to 100% constant. Ram at about 9gb, GPU 0% in use, vram 0 gb in use.

I have tried full screen, windowed mode etc… Am unable to get the game to even get to the main menu and loading of the initial credits/title screens is at a 1 FPS speed slide show until I finally kill task.

Note to devs: Is there an official feedback bug report location for these initial test builds you are sending out to backers?

I had the same issue. Most of the initial loading screens would hang indefinitely (they did actually eventually load up, but it would take a few minutes!)

I was unable to test the game properly because once I was in game I was getting about 1 fps and it would grind to a halt.

There is an integrated bug report tool in the Backer Build, but since you cannot access it, the forum is the next best thing – one of the reasons for the new forum software actually was to allow for better collection of feedback and bug reports.

I have seen a few reports like yours, all apparently running a resolution higher than 1080p – you might for testing purposes try to go back to that resolution with 1 monitor only; while I cannot guarantee this would help, it would at least provide a clue as to wether or not the 4K or in general higher than 1080 resolutions might be an issue.

Same here. I tried to run and get black screen. Eventually I get a License agreement screen but cant get past there. It runs incredibly slow.

Possible fix: (it was for me anyway)

Ran the game fine in 3440 x 1440 with no issues. Today when I tried to boot it up I suddenly experienced the sluggfest you described.

Turns out windows had compressed the files to save space on my SSD.

I fixed it by rightclicking the (phoenix Point) folder and selecting properties
Under the General tab; click Advanced… and a new window titeled Advanced Attributes will appear
Here, near the bottom of the window, make sure that the Compress contents to save disc space checkbox is NOT marked.

Hope this helps.

Happy crabstomp!

Still occasionally very long black screen loading screens.

I too am having this issue. My PC is i7 with 64 GB Ram running on an SSD. THe intro screen loads and is sluggish as if I am streaming an HD video on a phone line, then screen goes black, wait several minutes and nothing. :frowning:

I’m getting this as well, to the point that the game is completely unplayable. Has there been any word from developers on this issue?