BB5 Bugs: +video evidence

List of bugs, explanation and video

[Exploration bug @world map] Level: minor video https://www.twitch.tv/videos/478269861
[Reproducible] all the times when leaving unexplored point A for another point B and while in mid flight to B you can click on A and start Exploring it(tho it wont finish) Reproduced video in slow mo https://www.twitch.tv/videos/478353282

[Infinite ammo bug] Level:ultimate cheat :wink: video https://www.twitch.tv/videos/478273368
[Reproducible] items remain as - even after restarting game
cause probably code has minus variable on loot
infinite ammo if you move minus ammo to you soldier inventory it creates normal ammo you can scrap - and + ammo… scraping - ammo creates more of - ammo
Update After playing some more, the I think the - ammo comes from autro refill after mission, and I think it has something to do with auto refill of ammo after the mission on only the ammo you cannot produce yourself.

[Finishing a mission bug] Level: game breaker https://www.twitch.tv/videos/478279058
**[repro:unknown] **
You cannot exit map after results

[Will Power bug] Level: minor https://www.twitch.tv/videos/478282518
**[repro:unknown] **
UI shows soldier having 3 will power but cannot use dash that costs 3 will power, but can use Quick Aim that uses 2WP

[Aiming thru wall bug] Level: minor https://www.twitch.tv/videos/478285370
**[repro:unknown] **
Maybe prefab problem no hitbox? Or just glitching.

[Deployment bug] Level: possible game breaker, or Moderate https://www.twitch.tv/videos/478287779
[NOT Reproducible] one time wonder
Issue: The game has at the moment not very good troop/inventory system*1 (in my opinion)
the bug: I was getting my troops ready to deploy, and went into inventory to see if all was ok… then selected soldier what wasn’t on the plane with me and pressed BACK button and game glitched. After filling in game bug report I got game working without restarting … dunno how. Maybe pressing ESC.

*1 explanation: Player has ability to see the troops all over other bases or planes in same instance, while this is good so you can see ALL your troops this is not good if you want to see only troops in 1 plane coz its shuffles thru all the troops and not the ones you are trying to deploy.

[Manticore control bug] Level:game breaker https://www.twitch.tv/videos/478295124
[Not Reproducible] all the times happens some times count at 2 different times atm
Issue: there is some control problems when having multiple Manticores close by, maybe because at the moment you can select 1, 2, x and ALL Manticores. This happened to me on multiple occasions but not as badly as in this video (in those other cases I lost control of the Manticore, and it did something that I didn’t want it to do as in fly to same place as the other one)

[Throwing a grenade bug ] Level: minor https://www.twitch.tv/videos/478301988
**[repro:unknown] **
Some UI element got stuck on while trying to throw grenade.
Trigger: I was in first person trying to aim thru the wall with that soldier just before throwing a grenade.

[Mark for Death bug] Level: minor inconvenience https://www.twitch.tv/videos/47831338700
[Not Reproducible] one time wonder
when applying MFD on target player is not able to shoot while having ammo and AP in weapon… there is text saying “requirements has not been met”

[Shot gun point blank shot (not bug)] Level: minor inconvenience https://www.twitch.tv/videos/478318677
This is not a bug(probably), but this demonstrates that there should be maybe some UI Text Box element where it would say what happened in game coz some times camera is at bad angle and you cannot see incoming damage or shots that do 0 damage.

[Production reset bug] Level minor, HUGE inconvenience https://www.twitch.tv/videos/478323796
[Reproducible] all the times
bug: For some reason when removing something on queue and adding same weapon on queue retested timer for the one that was under construction

[Black Window at start bug]
[Reproducible] nothing happens on screen when starting a game from 10sek to 3minutes its kinda random, happens maybe coz alt tabing from game at start, maybe bcoz of streaming software is trying to capture game window? Or something else.

2 Likes

Tagging in QA Lead @gamingmechanoid

1 Like

Le more bugs saga:

[Collider box bug] Level: minor https://www.twitch.tv/videos/479023266
Some of the assets like this fountain thing, have their colliders set as one big collider(my guess) so you cant shoot thru them or aim.

[Load game/Save game bug] Level: Game breaker https://www.twitch.tv/videos/479275581
Some times Game Saving just breaks, happens to me 2-3 times already. After failed attempt I loaded first wrong save (works fine just 1h older) then tried to loaded right one “correct” game but it was broken.
First of all it counted my pre deployment save as failed mission that I was about to start (during game enemies destroyed key structure) so it gave me -rep etc.
Then for some reason as you can see in later part of video it copied all the gear for my team(you can see this as the report of looted items right at the start of video) that went to that mission into my main inventory and I had like 203/200 (in red inventory space, my real inventory is max ~40/200).
I tried to save this Corrupted game but it didn’t allow me, its remains as auto save before deployment.
Loading that 1h older file works and you can save it as new save. Corrupted doesn’t save at all.
–Update– Just started PP and loaded that broken autosave… and it works fine o_o, so its some kind of memory leak maybe?

[Boom Blast + Goliath bug] Level: minor https://www.twitch.tv/videos/479428021
BB ability works fine with throw able grenades, but with Goliath launcher it never allows you to shoot past its normal range.
If I remember correctly, in bb4 it was working with Goliath just fine.

[Pathing bug??] Level: minor inconvenience https://www.twitch.tv/videos/479429453
Some air conditioner is in the way, so basically need to run around whole building 2nd floor to go on the other side of that air conditioner
Maybe not a bug, if not can we have Bash ability on some minor clutter? :slight_smile:
I wouldn’t mind burning AP to get thru tho.

[Will Power area bug] Level: minor https://www.twitch.tv/videos/479430578
Didn’t get will power from WP area.
Also on same note if you use heavy’s rocket jump ability and land near box at the point where it should open and give you WP, this also doesn’t work you need actually walk 2 more tiles to the other triggerable side of the box.
Same thing second time https://www.twitch.tv/videos/479510496 So it’s not enabled in the asset prefab, my guess.

[Crab man spit bug?] Level: Game Breaker https://www.twitch.tv/videos/479506871
Dunno what happened there but, lots partially control over Berserker after he got spitted on by Crabman.
When I tried to save the game, it wouldn’t let me … so there was save game bug present also (broken level)
This was my first attempt at that particular level, after couple of tries on 4th try the level bugged and I guess Mist Spawner was bugged (it had “preparing” sound playing of it but it was already dead) and there were no enemies to my knowledge at level (I used “win” command to pass the level (a viewer told me there were such command, props)) video of that +3min https://www.twitch.tv/videos/479509749

[MFD bug 2] Game breaker https://www.twitch.tv/videos/481726138
Attempt to mark target with “Mark For Death” without line of sight broke game (it got in some kind of loop even win command didnt help)

[Civilian bug] Game breaker https://www.twitch.tv/videos/481727592
Civilians bugged out on their turn (win command WORKED)
–UPDATE– AI BUG game breaks on NPC turns(this happened after hotfix? it there was one this week)
–repro-- https://www.twitch.tv/videos/481810344
–repro-- https://www.twitch.tv/videos/481811666

[Manticore control bug repro] breaks part of the game https://www.twitch.tv/videos/481728796
Again for some reason had both of Manticores selected and turned the one in mid flight (not the one I wanted) sent to destination and the one turned in mid flight I lost control of it, it never can get to destination is like 0,0001 form getting there (maybe ran out of fuel in mid flight)

[Loading level bug] Game breaker https://www.twitch.tv/videos/481731150
My guy got killed, tried to reload level it stuck on loading video is like +2min as it loads, I alt +f4 after those 2 minutes, coz usual load time is under 10sek

[Adrenaline rush + Rapid clearance = OP] Unbalanced abilities ehehehe
Assault + Berserk class atm using those both skills is kind of broken :wink: video of me killing whole dungeon wiht one guy in 1 turn https://www.twitch.tv/videos/481807318