BB2 - Problems with gamepad controls

1. Controls
As the game settings gained a new “gamepad” option, I’ve connected a PS3 pad attached via USB cable. The results were mixed.

The controls that worked:

  • moving the camera on the map and selecting destination with analog sticks,
  • switching soldiers or targets with triggers L1/R1,
  • entering overwatch with “triangle” button,
  • swapping weapons with “square” button,
  • accepting with “x” button and cancelling with “circle” button,
  • skipping turn with “select”.

The rest of controls that are not active:

  • directional pad L-R should rotate the map and U-D change the height level,
  • secondary triggers L2/R2 should zoom in and out,
  • pressing the analog sticks L3/R3 should display unit details or enter manual aiming,
  • the “start” button should enter game menu or options.

I’ve tried to change control mappings on the starting screen, but it seems that some of the buttons (D-pad, L2/R2) are not being detected as pressed and therefore cannot be mapped. The PS3 gamepad is OK and it’s working properly with Darkest Dungeon (GOG) and FiraXCOM (Steam).
Can someone confirm this issue?

2. Camera
Also there still exists the problem known from BB1, where having the gamepad connected - and mouse pointer visible - causes the screen to drag and scroll one side until the edge of the map. It can be somewhat fixed by moving the mouse cursor at the exact center of the screen, but it helps only for the duration of the turn.
I am aware of the topic: Camera cannot be controlled however the system is not Windows (Ubuntu 14.10), the mouse is disconnected, touchpad disabled and the only USB accessory is a PS3 gamepad. But still the camera cowardly runs away from the action.
Any idea of how to fix that?

Can you post the version of DS4Windows you are using and the config of the active profile?

I’m playing on Linux (Ubuntu 14.10) without any specialized drivers or additional apps for gamepad management, so I guess the full controller support has to come with the game itself.

I’m suspecting the scrolling camera issue is caused by not disabling the mouse pointer (in other games when switching to the gamepad, the mouse cursor disappears from the screen) - which is now colliding with the controller input, so the game “thinks” that mouse pointer is the tilted analog stick which causes screen scrolling.

As for the not detected button controls, I’m not sure if there is a difference and eg. XBOX gamepad would work better as I don’t have access to test it. But in FiraXCOM EW (Steam) after switching input to XBOX controller and connecting PS3 pad, all buttons work exactly the same as in FiraXCOM EW PS3 version, although labelled with XBOX symbols. So I guess the input signals have to be somewhat similar.