After playing one mission the game hangs on the next

If i play one mission the game hangs on the loading screen with the manticore landing on the next mission. For reasons i wont get into i have the game on both epic and steam. I have tried with both epic and steam and the game hangs on the second mission i try and play. I have have had this game since before it launched and after release i was able to play the game fine and that was after the manticore loading screen was added. If i could hazard a guess its something with the year one edition because before that the game was playable.

When the landing screen freezes, try pressing ESC. There has been a bug since the Unity Engine update that causes this for some users.

1 Like

Having the same issue, will try:

When the landing screen freezes, try pressing ESC. There has been a bug since the Unity Engine update that causes this for some users.

Also more than meat the min spec, but the game just keeps going to black screen or minimizing to the desktop after 10 to 15 min playing. Also I have my laptop set on Turbo and nothing is heating much past normal temps. I went digging for log files, and cannot find a single crash report. Also this is what I am running on (And yes I have the full DxDiag if you want)


System Information

Time of this report: 12/6/2020, 20:55:53

  • Machine name: FARSCAPE
  • Machine Id: {CD241F81-4A19-4EC7-BC76-01426B16DB58}
  • Operating System: Windows 10 Pro 64-bit (10.0, Build 19042) (19041.vb_release.191206-1406)
  • Language: English (Regional Setting: English)
  • System Manufacturer: ASUSTeK COMPUTER INC.
  • System Model: Zephyrus S GX502GV_GX502GV
  • BIOS: GX502GV.310 (type: UEFI)
  • Processor: Intel® Core™ i7-9750H CPU @ 2.60GHz (12 CPUs), ~2.6GHz
  • Memory: 32768MB RAM
  • Available OS Memory: 32618MB RAM
  • Page File: 12115MB used, 53271MB available
  • Windows Dir: C:\WINDOWS
  • DirectX Version: DirectX 12
  • DX Setup Parameters: Not found
  • User DPI Setting: 120 DPI (125 percent)
  • System DPI Setting: 120 DPI (125 percent)
  • DWM DPI Scaling: UnKnown
  • Miracast: Available, with HDCP
  • Microsoft Graphics Hybrid: Supported
  • DirectX Database Version: 1.1.7
  • DxDiag Version: 10.00.19041.0546 64bit Unicode

Escape did nothing, and Windows still reported the game hung. I am running on high, and these are my temps.

Also this is my video card and driver version:
GPU processor: GeForce RTX 2060
Driver version: 457.51
Driver Type: DCH

Next this is what my windows logs say:

The program PhoenixPointWin64.exe version 2019.4.10.4531 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
Process ID: 5440
Start Time: 01d6cc56c243f203
Termination Time: 8
Application Path: C:\Program Files (x86)\Steam\steamapps\common\Phoenix Point\PhoenixPointWin64.exe
Report Id: 39e0159f-3326-47e7-8667-a1b716a275c9
Faulting package full name:
Faulting package-relative application ID:
Hang type: Unknown

And I dug through both C:\Users[USER]\AppData\Local\Temp and C:\Users[USER]\AppData\LocalLow\Snapshot Games Inc\Phoenix Point and found no crash logs at all.

PS - F10 only works before the game crashes. Also I played for 15 min then a crash, 10 min, then 1 hour, and then 5 min. During the last play I tried F10 the moment the screen when blank, but nothing. then the game minimized, and then when I tried Alt+Tab to it, Windows let me know the app had hung. Each time F10 would not work.

PPS - I also tried with my antivirus disabled, and made sure to add exceptions for the game as well as run PhoenixPointWin64.exe as an admin. No change, still having black screen then crash.

Are you playing it windowed, borderless or full screen?

I think F10 only works if the game is working as usual; in other conditions nothing catches the keypress.

Out of curiosity, would you try to leave the game still, i.e. in the Globe view and see if it still crashes / goes blank?

First tried full screen at my native resolution, 1920 x 1080, then tried borderless. Also did try lowering the graphic quality to medium, and still getting the crash.

Also to be clear, other games like Horizon Zero Dawn play fine at max settings so I am pretty sure this is not an overheating or power issue. What I am not sure of is if this a Unity issue, a DirecX 11 w/ latest version of Win 10, a driver issue or something else.

I cannot answer this question, because I have never gotten farther than picking up the 2nd squad member in the prologues 3rd mission. My last save is at the beginning of the 2nd prolog mission, and that crashed when I ended my first turn last time I played.

Just a vague guess: Do you have any HOTAS connected to your system? There were some problems in the past with such devices, but I don’t remember exactly if these also end in crashes.

BTW, your System should be more than enough, I have only a notebook with GTX 1650ti and no problems so far.

If you haven’t verified the game files, it’s worth a shot doing so. There is something afoot that is not quite right.

Nope, and no SLI. Right now there is a Bluetooth mouse and my wireless 7.1 headset, and that is it.

First thing I tried. I have not tried uninstalling and re-installing, as I just bought the game yesterday. Also I have tried this on wireless and a wired connection. Oh, and on both I get above 100mps.

The only other game I had an issue like this, is if I played in DirectX 11 vs choosing 12 (looks at Control).

That worked tyvm now i can play the game.

Did a complete re-install of the game, a clean install of my graphics driver, and timed my hard drive. Still crashed 2 times tonight. First it appears this may happen when my heavy or sniper crits, as both had spattered an enemy right before the crash.

Update - getting crashes after such things as ending a turn, and picking a party member, telling them where to move and bam black screen. Also I can sit on the initial load screen or just sit there waiting to pick things for over 30 min (tested while making food) with no crashes. Also all cut scenes and so on play fine, this game is crashing out when I try to issue orders to my squad randomly.

Ok I think I finally got to the bottom of why the game was hanging. I was also having audio drop outs when playing anything from iTunes, to Netflix, to a game. Did some digging and came across someone that was having trouble on the current windows revision, and turned out to be an Intel driver issue with their hard drive set to Intel RST Premium, which mine was as well in bios. Just be warned, while this did fix a whole host of anointing small lag issues with my laptop, I did get to re-install windows after swapping to AHCI in bios under my SATA controller.

For extra fun, my laptop did not come with Intel Optane RAM so there was no reason to set the M.2 drive to this setting in the factory, Also 1/2 of my 32Gb of RAM is soldered to the motherboard, so there is no way for me to swap to an Optane RAM setup. :woman_facepalming:

1 Like