UI scales wrong with 3440 x 1440 (Xbox Gamepass for PC)

The UI is very oversized in 3440 x 1440 and makes the game unplayable. Information and buttons are pushed of screen and unusable

3 Likes

1 Like

2 Likes

Came here to post this exact problem - just started game and can’t do first mission because the ‘Start Mission’ button is way off the bottom of the screen. Bringing resolution down scales correctly but… fix 3440x1440 pls

1 Like

UI does not scale on ultrawide in windows store version cheap console port.

I have the same issue at 2560x1080 on my Ultrawide monitor. An ‘easy’ fix might be to have the enter key use the UI element that starts missions… Or at least that would let us play the first mission.

Edit: I tried adjusting my resolution, but as all the resolutions I get are the same aspect ratio and the UI seems to have an issue with the aspect ratio none of them helped.

This is happening to me too. I’m using a 34" Asus Ultrawide running 3440x1440. I’ve tried Borderless, Fullscreen, Windowed, and they all cut off the “Start Mission” button, or “Ok”, etc. I’ve never seen this on any other game on PC. Period.

On top of that, there are these buttons at the top and bottom of screen that pop up the windows taskbar? It covers certain actions and just opens up the taskbar and makes it almost unplayable; especially with these 2 issues combined.

I had to click the “windowed” button in the top right to get the game into a tiny window so that I can press “Start Mission” etc and then I can go back to normal, but obviously this is extremely annoying having to do this constantly.

I’ve actually never seen this happen before with any other game on game pass for PC, Steam, etc., unless they specifically state that ultrawide is not supported.

Very annoying.

2 Likes

Yep I am having the exact same issue. Very disappointing given the delay of getting on gamepass then it turns into this buggy mess. Wow, just wow!!!

Same issue for me. Has anyone compared the options.jopt file with the XGP version to the Epic store’s? Perhaps it is a setting we can change?

Came here to check if this issue has been fixed or not; glad to hear it is at least working properly for the Epic Games Store version which means the Xbox Game Pass fix probably isn’t too far away.

Thank you Devs for a wonderful game! Looking forward to the patch so we can enjoy it more :slight_smile:

1 Like

Same here - this is really bugging me an otherwise great game I am enjoying - devs please fix this!

For those struggling with this issue, a temporary fix is to run the game windowed at a much lower resolution - the UI scales properly with dialog boxes fully on screen.

I’m having the same issue as well. I found running it 2560x1440 in full screen works, although is clearly not ideal.

Has there been any progress made with this issue? I don’t see it added to a list of known bugs although that list has not been updated since April. I understand that the Epic Game Store version does not have this issue.

I suspect the UI scaling is set to scale with the width only, so the greater the width the larger the overlaid elements of the UI. This is the default behaviour of UI elements in the Unity engine and as this has already been resolved in the Epic Store version I imagine changing that flag for the Game Pass version shouldn’t be to much of a deal, just need confirmation that the developers are working on this?

I would very much like to sign up for the season pass based on my time with this game on a 1080p screen but on my main PC with an UltraWide it is unplayable due to this.

I would also like to know if this is actively being worked on. I can’t play either on xbox gamepass because I have an Ultrawide setup and UI isn’t scaling as all have mentioned.

Yup, same problem here, game is useless until they fix it.
I tried looking for a config file that contains the screen res to reset it back to the default, but no luck.

16 days since this post and no official response! Has this even been acknowledged by the dev team yet?

I imagine most of the team will return from their holiday breaks this coming week so it’s understandable there has been no response, we are all entitled to a break. I am happy to be patient until we get confirmation this will be resolved in an upcoming patch I can play on my area51m for now.

This seems to be resolved. I randomly switched back to 3440x1440 and everything is okay.

Yep, can confirm this is now sorted :slight_smile: