Pheonix Point install error on Epic client

ARGH the epic store says its available since 3 hours, thats a LIE…godamn im completly freakin out…Sorry but i WANNA play it and dont want 2 read its rdy 2 go or its release in gtm is soon…NOW if the store says available i wanna get 2 it, since 3 hours!!!
Im not the slightst hyped here…

you can install since 40 minutes

1 Like


is all i get :frowning:

me too why sow anoing

i just tried another restart of the epci launcher and tried the phoenix point dl NOT the pheonix point content dl, now its working!!!

My download started so fast it should have been finished by 19:45 CET. It’s slowed right down now, to the point where it’ll not be ready till 20:15 CET at least… :confused:

1 Like

no for me :frowning:

Nearly there…

7:10pm here in Scotland (GMT) and still can’t get it same error!

Doesn’t work for me, getting error code MD-0011 when I try to download it. :expressionless:


This error means that the launcher was unable to download necessary information for installing the product. This is generally the result of a network connectivity issue, but can also be due to a problem with our servers. If you are receiving one of these errors, please do the following:

  • Try our network connectivity troubleshooting.
  • If that doesn’t help, wait a little while and then try again. If the problem is a temporary server outage, it will be corrected shortly.

Last Updated: 81d • Permalink


epic listed 2 instances of the game for me one called phoenix point content the other simply phoenix point. installing the one called phoenix point made it work try doing a search in library


thanks! seems i clickt the whole time on the wrong tile/button. in my launcher are three entrys for PP.

Your a genius!

yep you a one epic is stupid :face_vomiting:

Yeah, I solved it on my own just now too, I was trying to DL the “content”, but there’s two entries, phoenix point and phoenix point content, so make sure you don’t try to DL the wrong one.

I was noticing how Epic lists all the DLC too. That is kind of ridiculous…game studios must hate players to make them use epic’s UI. Dear GOD it’s bad.

I’m in the UK and still getting that error message.

Typical, just as soon as I posted that it started downloading :smiley:

The game downloads 15.1GB but the content throws up this error.