Pheonix base defense - infinity loading after Orryx patch

No mods have been installed. Unable to defense base because the game won’t load a mission.

Loading screen:

Base location:

Save game: Dropbox - Geoscape_23_02_2047_5.zsav - Simplify your life

1 Like

Same to me. last “patch” broke this . Cant play.

Yes, the same problem after patch

Same here. with the corrupted saves bug and the loading bug there goes the campaign…

Same here. Uploaded 2 files via the in game reporting app, and stated this on the steam forums as well.

Same here.

I am trying to clear a newly activated base that was in the mist, from infestation. The battle will not load. the Load process starts and hangs at about 25%. Tried it on two different bases, with the same result. Tried it with one and two aircrafts, the same result. Other battles for now do load OK.

Need help on this one.

Problem with base missions not loading: Should be affecting only EGS (Epic Games Store) version. If you have that problem on other Store you should be able to fix it by verifying your game installation (this is how you do it on Steam: Go into Library>right click on Phoenix Point>Properties>Local Files>Verify integrity of game files).

on EGS the base files cannot be loaded. That means you cannot play base defense or base infested missions on EGS right now. We are going to fix it as soon as possible.

Possible workaround: You can skip base defense missions by pressing cancel when the mission appears- see screenshot. This way your facilities will be damaged so I recommend demolishing them before the attack to get some resources. Sorry for the inconvenience.


Thank you for your answer.
May I ask you a favor to post an update on this topic when the fix is ready?

Should go live in few hours from now


Nice! That is fast response and fixing.
BTW great game it is much better at capturing the old feel of XCOM then the new games of the same name.
The free aim is spot on, not like their crap version.

1 Like

Quick thank you for the fast fix!
The free aim is a game changer!

Many thanks for the quick fix of this issue. The game is really good. Better than new X-CCom and many other tactical games

Exact same problem through EGS.

Eagerly awaiting fix. I only have the autosave to start the base defense mission, and one and only save from yesterday at the first turn of the base defense mission, so my current playthrough would be completely lost without a fix, haha.

Of course it’s an excuse to start a new playthrough. Maybe Anu this time.

The fix is live