Game bugged beyond redemption

Hi Guys! I have developed a strange hate & love relationship with Phoenix Point and want to submit some bugs i have found very disturbing.

1.) Savegames are often not loadable on certain mission (espacially with Anu Defend Scenarios)
An issue which pisses me off because i lost a lot of tim

e due to it and it already happened 3 times since your last patch (An error occured while loading game level - see embedded screenshot + Savegame)

After this error occurs and u try to load another savegame the game will go in an infinite load screen. Only way to fix it is Alt + F4 and relaunch (and dont touch the damaged savegame(s))

2.) The Game likes to think very long when you remove a Mindfragger with the Technican ability or isnt responding anymore.

3.) Some tooltips overlap important information in the characters / Trainings section in the 3rd row of the character abilities.

4.) German localization is not complete and sometimes text is in english.

5.) Scylla queens still spawn Mindfraggers even if you destroy the abdomen (worked before patch).

  1. Some missions are straight out impossible espacially if you defend havens with key structures of civilians. Sometimes 5 Mobs spawn right next to your mission objectives and kill it very fast.
    Same goes for crates who cant take a lot of damage. Very annoying.

A lot of “small things” hinder this game to be at the top and even outlast XCOM 2 War of the Choosen.

I hope you will invest some good time in fixing the zillion small bugs.

With regards


1 Like

Verrify your game catch, and head to the save file location C:\Users<USER>\AppData\LocalLow\Snapshot Games Inc\Phoenix Point\Savegames whipe it.

This should fix the problems. Had similar ones my self. Turned out it was do to some corrupt files.

On all points 3-6 those are valid and this isn’t the first topic pointing them out. but the first one I know of from personal experience is a corrupted file.

1 Like

Hello! Thank you for your answer but it didnt help. I have 2 folders. First one is named “Saves” and the other one is named “d11ac29b98a54a349711f1d1a1b48d73”. I tried to delete all of the Savegames and downloaded them from the cloud again. Same error message… couldnt load the level.

Any more inputs?

Ok when the error pops up hit I think f12 and send in a full bug report. That should send snapshot pretty much anything on the game file that is needed to find out what is going on.

1 Like