Linux build failing to load game

Raised initial issue on Reddit here. Ran the executable via a terminal and output lead me to the log location. This is the end of it, Seems to have trouble loading some particle effects and their fallbacks. CPU keeps using a full core despite nothing happening as a result, just a blackscreen and close to 4GB of RAM used(1.4GB this time round with potato graphics instead).

Desktop is 1920 x 1080 @ 60 Hz
Shader 'Particles/FXVille Blood World Lighting': fallback shader 'Paricles/Alpha Blended' not found
Shader 'Particles/FXVille Blood World Lighting_epp': fallback shader 'Paricles/Alpha Blended' not found
UnloadTime: 0.702000 ms
Quality level: 1, setting post processing profile: FDM_PostProcessingProfile_Intro_Low (UnityEngine.PostProcessing.PostProcessingProfile) to camera 'MainCamera'.
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

The referenced script on this Behaviour (Game Object 'VFXConv_AssaultRifle_Projectile') is missing!
(Filename:  Line: 1758)

The referenced script on this Behaviour (Game Object 'ParticlesLight') is missing!
(Filename:  Line: 1758)

The referenced script on this Behaviour (Game Object 'ParticlesLight') is missing!

Would be great to play this on Linux, it’s one of the factors that had me pay :slight_smile:

OK, let’s try to debug this step by step and get some more info, that might be helpful to devs:

  1. Please report which version of the game are you trying to run; I am testing: Phoenix_Point_0.1.23108_Linux; in-game this is reported as “System revision 23107”. Unfortunately, game version reported after you start a game, so in case you can’t find it (it’s missing from release notes :confused: ), run md5sum on file PhoenixPoint.x86_64.

    $ md5sum PhoenixPoint.x86_64
    148e524e95c8daf36bdc21ad5b6742fc  PhoenixPoint.x86_64
  2. Have you tried to wait for the game to start for few minutes? There is no loading screen ATM. I am running from SSD as well, and it takes ~30s for a black screen to be replaced by the menu.

  3. Please report:

  • kernel version and what graphic card are you using. I am testing on:

    $ uname -a
    Linux tars 4.16.16-200.fc27.x86_64 #1 SMP Sun Jun 17 03:06:00 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

    using GeForce GTX 770, driver version 396.24. I wouldn’t expect the game to run on older Intel cards nor nvidia+nouveau.

  • Did you unpack game to location with write access? (somewhere in your home dir as opposed to e.g. /opt)?

  • How much disk space do you have left?

  • Do you use X server or Wayland?

  1. Based on your logs, the game has a problem with loading a shader - maybe due to a corrupted file, so let’s check. As far as I can tell, all shaders referenced in your log are in PhoenixPoint_Data/sharedassets0.assets file. md5sum of my file is: e95a1ef0ebbf0e2dbdfde2afee0ac46e.
  • In case you want to check other files, here are checksums of all files. Use following command to generate checksums on your own:

    $ find . -type f -exec md5sum '{}' \; > all_files.md5

    And then use diff (or maybe meld), to compare.

Hi, thanks for the detailed troubleshooting steps. I’m unable to do most as I’m in China for the next few months away from my main PC.

I was running Manjaro KDE as my distro fully up to date. Kernel I believe was 4.17 with proprietary drivers for my Gtx 1070. Yes I have had it wait for over 10 minutes and the disk has over 100GB free, the files were unpacked in the ~/downloads folder, so it should have had no issues with write privileges. I didn’t consider checksums, so it may be possible something went wrong there, not sure what the version was, latest from the download site at date of posting. I use X server.

I’m running Arch with KDE and nVidia GTX 1060 using proprietary drivers (390.48). Both backer builds have worked fine for me. I normally launch it from Dolphin, rather than the terminal, though both work. I agree that checking for a corrupt file is a good start, and now that a new build is out trying that. Manjaro is close enough to Arch that it likely isn’t a distro issue.